Help with external HD powering down
Feb 28, 2007 at 3:08 PM Thread Starter Post #1 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
Hi all,

I bought a Western Digital external hard drive that I connect to my laptop through an USB port. I have ripped all my CDs onto this drive and am using Foobar as the player.

When I'm listening to music every once in a while the hard drive will power down because it thinks it's not being used. It powers right back up, but the hiccup is a little annoying. Is their a way I can set the hard drive so it does not automatically power down?

Thanks.
 
Feb 28, 2007 at 4:16 PM Post #2 of 16

HFat

1000+ Head-Fier
Joined
Dec 24, 2005
Posts
1,061
Likes
10
I assume you are using your OS's default driver for USB drives... in that case there may or may not be a way to fix that by changing some of your OS's settings.
Maybe you should state what's your OS and, in case no one can help you here, go ask the people who made that OS or some kind of support forum for that OS.

In any case, a simple fix that should work in all cases would be to force that drive to get busy every couple of minutes or so (by reading something or, if that doesn't work, by writing in a dummy file).
There are a number of ways to accomplish this automatically but it would probably be best to leverage whatever scheme you're already using to do things at regular intervals (for example, Windows has a thing called task scheduler or some such which is enabled by default).
 
Feb 28, 2007 at 4:56 PM Post #3 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
I'm on a Gateway laptop running Windows XP Home Edition. I'm looking for a setting for the external hard drive similar to the Power Management power scheme settings that the laptop has under its properties. I can have my laptop hard drive power down after a certain amount of time if it is not in use or I can set it so that is never powers down to save energy. I was hoping that there was a similar setting for the external hard drive, although I could not find it. If the only fix is a kludgy one, I'll just leave it the way it is since it's only a minor annoyance right now.

Thanks for the information.


Quote:

Originally Posted by HFat /img/forum/go_quote.gif
I assume you are using your OS's default driver for USB drives... in that case there may or may not be a way to fix that by changing some of your OS's settings.
Maybe you should state what's your OS and, in case no one can help you here, go ask the people who made that OS or some kind of support forum for that OS.

In any case, a simple fix that should work in all cases would be to force that drive to get busy every couple of minutes or so (by reading something or, if that doesn't work, by writing in a dummy file).
There are a number of ways to accomplish this automatically but it would probably be best to leverage whatever scheme you're already using to do things at regular intervals (for example, Windows has a thing called task scheduler or some such which is enabled by default).



 
Mar 1, 2007 at 2:13 AM Post #6 of 16

fwojciec

100+ Head-Fier
Joined
Apr 29, 2006
Posts
327
Likes
10
Quote:

Originally Posted by noobie72 /img/forum/go_quote.gif
Hi all,

I bought a Western Digital external hard drive that I connect to my laptop through an USB port. I have ripped all my CDs onto this drive and am using Foobar as the player.

When I'm listening to music every once in a while the hard drive will power down because it thinks it's not being used. It powers right back up, but the hiccup is a little annoying. Is their a way I can set the hard drive so it does not automatically power down?

Thanks.



This has to be disabled using jumpers on the actual hard drive, if I'm not mistaken - I've had a similar problem in the past. You will have to open the enclosure, take the actual hard drive out and change the jumper setting there.
 
Mar 1, 2007 at 2:47 AM Post #7 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
If I do this, will the hard drive shut down when I turn my laptop off? I was hoping for a simpler solution. If not, I just live with the occasional hiccups.

Thanks for the info.



Quote:

Originally Posted by fwojciec /img/forum/go_quote.gif
This has to be disabled using jumpers on the actual hard drive, if I'm not mistaken - I've had a similar problem in the past. You will have to open the enclosure, take the actual hard drive out and change the jumper setting there.


 
Mar 1, 2007 at 9:07 AM Post #8 of 16

db597

100+ Head-Fier
Joined
May 29, 2006
Posts
457
Likes
10
Quote:

Originally Posted by noobie72 /img/forum/go_quote.gif
I can have my laptop hard drive power down after a certain amount of time if it is not in use or I can set it so that is never powers down to save energy.


I think there's only 1 setting for all drives? If you set this to never power down, does your external HD still power down?
 
Mar 1, 2007 at 9:14 AM Post #9 of 16

Mrjabba

Head-Fier
Joined
Mar 1, 2007
Posts
59
Likes
0
try having a look at the settings in the power section of control panel.
there are settings there that make the hard drive turn off after a certain period of time.
you can also access the power settings in the screen saver tab of your display properties
 
Mar 1, 2007 at 1:32 PM Post #10 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
I have it set to Never and it still powers down. When I'm listening to music, the music will pause for a instance, then the hard drive will start spinning again and the music will come back. The whole sequence takes less than a second.

Now that I think about it, it sometimes happens when I'm listening to music from my internal drive. The music will pause for a moment and then start playing again. I can't hear the internal disk spinning, so I don't know if it's the same issue.

This problem occurs more frequently when I'm doing other things on the computer. If all I'm doing is listening to music, then it seldom occurs. Maybe the OS just doesn't handle multi-taksing very well.



Quote:

Originally Posted by db597 /img/forum/go_quote.gif
I think there's only 1 setting for all drives? If you set this to never power down, does your external HD still power down?


 
Mar 1, 2007 at 1:34 PM Post #11 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
I have this set to Never for the hard drives when the computer is plugged in and when running on the battery. I think it's just a limitation of the OS.


Quote:

Originally Posted by Mrjabba /img/forum/go_quote.gif
try having a look at the settings in the power section of control panel.
there are settings there that make the hard drive turn off after a certain period of time.
you can also access the power settings in the screen saver tab of your display properties



 
Mar 1, 2007 at 1:49 PM Post #12 of 16

db597

100+ Head-Fier
Joined
May 29, 2006
Posts
457
Likes
10
Found this on Google:

Possible Fix: Now let's fix this problem.

Click on "Start" and then right-click on "My Computer."
Click on "Properties" and then on the "Hardware" tab.
Half-way down on the right, click on "Device Manager."
Click the "plus" sign in front of "Universal Serial Bus Controllers."
Double-Click on the first "USB Root Hub" (not USB 2.0 Root Hub).
Click on the "Power Management" tab.
Uncheck the box that says "Allow the computer to turn off this device to save power."
Click "OK" and repeat for all other "USB Root Hubs."
Finally, close all and go back to the desktop.
 
Mar 1, 2007 at 2:24 PM Post #13 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
This looks promising. I'll try it out tonight. Thanks for the information.




Quote:

Originally Posted by db597 /img/forum/go_quote.gif
Found this on Google:

Possible Fix: Now let's fix this problem.

Click on "Start" and then right-click on "My Computer."
Click on "Properties" and then on the "Hardware" tab.
Half-way down on the right, click on "Device Manager."
Click the "plus" sign in front of "Universal Serial Bus Controllers."
Double-Click on the first "USB Root Hub" (not USB 2.0 Root Hub).
Click on the "Power Management" tab.
Uncheck the box that says "Allow the computer to turn off this device to save power."
Click "OK" and repeat for all other "USB Root Hubs."
Finally, close all and go back to the desktop.



 
Mar 1, 2007 at 3:15 PM Post #14 of 16

vo328

500+ Head-Fier
Joined
Dec 14, 2005
Posts
780
Likes
11
noobie72, which WD hard drive is it? If it's the 160gb passport model, then you might be having an issue where it's not getting enough power through the USB port. This is a common issue with this particular drive (it's power hungry) and in fact, WD sells a special cable for it. I found that my Dell D400 cannot provide sufficient power from it's usb bus, but my Dell D620 can. Just a thought...
 
Mar 1, 2007 at 4:48 PM Post #15 of 16

noobie72

100+ Head-Fier
Joined
Jan 24, 2007
Posts
121
Likes
0
It's this model:

http://www.bestbuy.com/site/olspage....=1134698030419





Quote:

Originally Posted by vo328 /img/forum/go_quote.gif
noobie72, which WD hard drive is it? If it's the 160gb passport model, then you might be having an issue where it's not getting enough power through the USB port. This is a common issue with this particular drive (it's power hungry) and in fact, WD sells a special cable for it. I found that my Dell D400 cannot provide sufficient power from it's usb bus, but my Dell D620 can. Just a thought...


 

Users who are viewing this thread

Top