Help with Dragonfly not changing colors

Discussion in 'Computer Audio' started by edgeworth, Feb 11, 2014.
  1. edgeworth
    Hi all.  I didn't find this topic after a few searches, so I'm asking for help here.  I just got the Audioquest Dragonfly (older version) and it installed nicely.  I set it to 24 bit, 96k but I thought that using it with Foobar2000 should allow the files to be processed differently for 16 bit vs. 24 bit material.  Yet, no matter what files I play, the Dragonfly always is a magenta color.  I must be doing something wrong but can't see how to change the settings in either Control Panel/Sounds or in Foobar2000.
     
    Any suggestions?
     
    Thanks.
     
  2. AsianBatman
    From their FAQ "As mentioned above, DragonFly performs best when audio data is sent to it at its native sample rate. To simplify this, DragonFly lights up different colors when it receives audio data at different sample rates: green for 44.1kHz, blue for 48kHz, amber for 88.2kHz, and magenta for 96kHz."
     
    If you are setting it at 96kHz then it is showing the correct color. The USB light does not correspond to the bit. 
     
  3. edgeworth
    I'm still not entirely clear on this.  Does that mean if I have a few 24/96 files it makes sense to leave it at 24/96 even if most of the files I listen to are 16 bit?  Or does that mean I have to manually reset the Dragonfly to 16 bit if I'm only playing 16/44 FLACs?
     
    Thanks.
     
  4. AsianBatman
    You can leave it at 24/96 and it will not affect the files you are listening to. Try it out and you will hear for yourself. 
     
  5. PleasantSounds
     
    Windows Audio will always output at the configured setting. If you want to transfer data to DAC at the native resolution, then you have to bypass the Windows Audio. 
    What you need is the WASAPI plugin for foobar.
     
    AsianBatman likes this.
  6. edgeworth
    Hmm.  I must be doing something wrong.  When I installed WASAPI and tried to set device output to WASAPI Audioquest dragonfly I got no sound even though WASAPI was installed.  So I went back to the default output as DS Primary Driver.  What should I use? I guess I'd ideally like it so that whenever the files are 16 bit, they get sent to the DAC 16 bit and if 24 bit then sent as 24 bit.  Isn't that better?  Or will I not notice a difference just leaving the Dragonfly at 24/96 and letting Windows send the output?
     
  7. PleasantSounds
    No idea why WASAPI does not work for you. It would be the best option to send the unchanged data to the DAC as most likely it upsamples it internally once again before converting. If that doesn't work, 24/96 is probably your next best option.
    Upsampling from 44.1 to 96 kHz may introduce some very subtle artifacts, but it's unlikely you would notice them. One trick you should try is to do the upsampling within Foobar rather than letting WIndows handle it. Foobar has a very good resampler plugin (SoX) - set the target sample rate to 96 kHz and quality to Best.
    Conversion from 16 to 24 bit is harmless and will not degrade the sound quality at all.
     
  8. aliphares
    I know i'm late to the party but i have the same issue with the 1.5 version. The color is whatever default format i choose, irrespective of if i choose a 3mb mp3 file or a 130 mb flac file. If i want it to choose the native format (which is the best to do i guess) how would i change the drivers? Also, would that still work if i was using spotify?
     
  9. Shahram
    I'm having the same issue. Seems like there should be in option in windows to not set the rate at all and only allow whatever music player you're using to decide the sample frequency.
     
  10. LudoLVG
    Just try this evening and just had the dragonfly black since last week.
    Same issue.
    But I don't try the wasapi driver option (not installed I think) I tried just the DS output
     

Share This Page