Help needed: Virtual Grounding, Hum, Distortion, and me throwing something out a window.
Jun 22, 2010 at 7:01 PM Thread Starter Post #1 of 11

Tridacnid

1000+ Head-Fier
Joined
Jun 10, 2007
Posts
1,053
Likes
10
Hey all. This isn't my first build, but I'm currently attempting the "Infinity Universal Preamp" for my bass guitar. And it ain't going too well. My building has always been a mess, but it works. So far, I've gotten audio to output, but it's incredibly distorted and there's a ton of hum. The hum is generated before the volume knob, as turning it down also reduces hum. The hum is not generated by the bass pickups (threw a 1M resistor in front of the bass and it still hummed). Could my somewhat ghetto virtual ground power supply be the culprit? 
 
The schematic (direct source): http://www.techniguitare.com/projets/ChaosPreamp/Preamp-Schems-V1.1-En.pdf
The thread that the project originated in: http://www.diystompboxes.com/smfforum/index.php?topic=74219.0
 
Anyways, what could be making the humming? And distortion? The distortion leads me to the power supply, because I know that an IC will distort if it isn't powered properly.
 
The virtual ground circuit mine is based off of (it uses the BUF632): http://tangentsoft.com/elec/vgrounds.html
 
EDIT: Forgot to mention that the rails in the VGC differ by about 0.1 volts without a load.
 
Thanks,
Tri
 
Jun 22, 2010 at 11:32 PM Post #4 of 11

jcx

Headphoneus Supremus
Joined
Jul 24, 2002
Posts
2,371
Likes
369
fig 5 tone control schematic doesn't have a DC path to bias the op amp input - I'd worry with such a basic mistake
 
Jun 22, 2010 at 11:54 PM Post #5 of 11

nikongod

DIY-ku
Joined
Jan 24, 2005
Posts
8,882
Likes
126
 
[size=medium]
Something of a common mistake when using virtual grounds is not maintaining a healthy respect for virtual and real ground.  
 
Your power supply needs to float if you are going to use a virtual ground. Its worth a moment to check on this if your using a wallwart. With the wart unplugged measure from "negative" (or not positive) to the ground pin. If its a good connection get a cheater plug. If that solves your problems figure out a safer way to make a floating supply.
[/size]

Quote:
fig 5 tone control schematic doesn't have a DC path to bias the op amp input - I'd worry with such a basic mistake


Unless I'm reading the schematic wrong it grounds through the pot at the end of figure4.
 
Is my PDF viewer weird, or did they draw the whole thing with razor thin lines in grey on white? 
 
Jun 23, 2010 at 2:23 AM Post #6 of 11

jcx

Headphoneus Supremus
Joined
Jul 24, 2002
Posts
2,371
Likes
369
fig 5: C1,3,4 completely DC isolate the -in of the op amp U2
 
Jun 24, 2010 at 11:32 AM Post #10 of 11

jcx

Headphoneus Supremus
Joined
Jul 24, 2002
Posts
2,371
Likes
369
but you'll still need DC bias/feedback path to the -input of the baxandall tone control U2 op amp - the circuit as shown in fig 5 of your 1st link will not work
 
Jul 1, 2010 at 11:52 AM Post #11 of 11

Tridacnid

1000+ Head-Fier
Joined
Jun 10, 2007
Posts
1,053
Likes
10
Okay, rebuilt the entire thing from the ground up. But I killed the 68nF cap in Figure 3. Replaced it with a spare 47nF I had laying around (closest thing I had) and the circuit didn't work at all. Finally figured out that Figure 3 was giving me the trouble. Replaced the cap with a 30uF cap (next closest cap I had), and now I get something, but one of the transistors starts going nuts when I crank the voltage.
 
Any thoughts?
 
And at jcx: What do you recommend I do? Stick a 10K resistor in there for feedback?
 

Users who are viewing this thread

Top