1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

HELP: Mac No Longer Recognises FiiO E7

Discussion in 'Computer Audio' started by qui audit, Sep 20, 2012.
  1. Qui audit
    After uprading to Mountain Lion's 10.8.2 build (from 10.8.1) I've found that my E7 just isn't recognised anywhere. It doesn't appear as a USB device and it isn't present as a sound output in System Preferences. 

    Does anybody have any ideas as to what could be causing the issue?
     
  2. Qui audit
    [Running a 2012 Macbook Pro 15 inch non-retina]
     
  3. dgriffter
    Hi, 
     
    I had similar issue; 15 inch mbp non-retina, not recognising e7. I was the rather flimsy stock usb cable. I swapped it for an old camera usb a to mini b and voila. I suggest trying the same. If memory serves me, I had a similar issue with a pc and my e10 and the same stock fiio usb cable. Maybe there is a known issue? 
     
  4. Qui audit
    I tried that and contacted FiiO, turns out there's a relatively uncommon but known fault with the micro usb port not connecting sufficiently with the usb cable. None of the cables I have worked, so I sent it back for a refund and am now investing in an E17!
     

Share This Page