Hello all! Also--solve my blown iem drivers mystery
Oct 1, 2015 at 11:29 AM Thread Starter Post #1 of 1


New Head-Fier
Oct 1, 2015
Hey folks,
By way of an introduction, my name is Jim and I live in Buffalo, NY where I teach English at a few area colleges.  
While I have always found the information in these forums useful, I have joined, for now, only because I have a specific question that hours of web searching have not been able to answer.  The story is perhaps a bit long, but please bear with me as I could use your help.
So, several months ago I purchased a pair of Shure se425's.  Shortly there after I noticed that the right iem would break-up and sound distorted in the higher frequencies at moderate to loud volume levels.  So, assuming there was a problem with the driver, I sent them back under warranty.  Now, I decided to buy a new pair of iems--Grado GR10e--in the meantime so that I wouldn't be without during the time that my Shures were being serviced.  Now here is where the mystery begins:  Shortly after getting the Grados, I began experiencing the exact same distortion as I had with the Shures.  My first reaction was to think that maybe I was just driving them too hard, but that wouldn't explain why it was the right side with each.  And, sure enough, when I got the Shures back last night, I plugged them in and found that they DID NOT have the distortion that I was now experiencing with Grados and had experienced with the Shures before service.
So, my question now is this:  Is it possible that one of the sources that I plug into is somehow shorting-out the drivers?  I plug into an Audioquest Dragonfly usb DAC, my Wyred4Sound mInt amplifier, and my smartphone.  The Grado's distort the same way across all three sources.  So far, I have tried the newly-serviced Shures on my hifi amp and the Dragonfly DAC and HAVE NOT experienced any distortion.  I HAVE NOT tried them yet in my phone.  Is it possible that my phone is somehow damaging these iems?  Again, two sets have experienced the exact same problems and I have not experienced this problem with a fresh set that has not yet been plugged into phone?  What do you think?

Users who are viewing this thread