Grado SR-60s hissing
Mar 7, 2006 at 11:32 PM Thread Starter Post #1 of 4

The_Duke_Of_Eli

Headphoneus Supremus
Joined
Feb 23, 2006
Posts
2,113
Likes
10
Plugged in my cans today and whenever there was low bass notes I'd hear like a scratching or hissing noise faintly in the right ear. I confirmed it by putting the right side on my left ear and the left on my right and the hissing was still in the right side of the headphones? Any suggestions? Should I just ship it back to Grado? Thanks.
 
Mar 7, 2006 at 11:43 PM Post #2 of 4

RedLeader

Headphoneus Supremus
Joined
Jun 6, 2005
Posts
3,413
Likes
11
sounds like a case of the grattles. Quite probably a case of hair on the driver. try blowing/sucking on the outside to get rid of it. I realize this may sound like something ridiculous to do, but it worked for mine.
 
Mar 7, 2006 at 11:46 PM Post #3 of 4

The_Duke_Of_Eli

Headphoneus Supremus
Joined
Feb 23, 2006
Posts
2,113
Likes
10
Quote:

Originally Posted by RedLeader
sounds like a case of the grattles. Quite probably a case of hair on the driver. try blowing/sucking on the outside to get rid of it. I realize this may sound like something ridiculous to do, but it worked for mine.


WIll try. So I probably wont have to send for warranty rite? I head about using compressed air; is that safe?
 
Mar 7, 2006 at 11:56 PM Post #4 of 4

The_Duke_Of_Eli

Headphoneus Supremus
Joined
Feb 23, 2006
Posts
2,113
Likes
10
SUcked really hard on the back and the issue is gone. And so is that hair :s. It was worth it to save my grado!
 

Users who are viewing this thread

Top