FS: Schiit Asgard Amp -- EDIT: power on LED problem
Status
Not open for further replies.
Type
For Sale
Currency
USD
Price
160.00
Feb 27, 2013 at 12:16 PM Thread Starter Post #1 of 6

J W

500+ Head-Fier
Joined
Dec 31, 2005
Posts
589
Likes
16
This is Asgard 1.
 
Purchased in 2012. Great condition. It includes power cable, original box, instructions, and rubber feet (which I took off and placed in a baggie). Price includes all fees and includes shipping.
 
I accept paypal and money order. I prefer money order and will negotiate a better price if you choose to go that route.
 
Edit: I noticed the power LED does not seem to be working. The amp itself still plays flawlessly. I had this sitting in its box unused for several months, but it seems like the power-on LED was working before I stored it. I'm sure it can be warrantied if it is a problem. I am dropping the price down to $160 in light of this.
 
Edit 2: I sent an email to Schiit and hopefully will get a response tomorrow.
 
Edit 3: Received response from Jason. It's a simple fix and apparently happens every now and again. Unfortunately, he wont ship it to a second person if I send it to him to be fixed. So, I can ship it in to get fixed but then will have to charge the original $169 shipped as it would cost me doubly in shipping charges. The price of $160 still stands for anyone who wants it as-is. I still prefer money order and would like to know which people are still interested given the LED problem as I have received a boat load of PMs, many of which were sent before the LED problem came to light. 
 
Very Best,
JW
 
Status
Not open for further replies.

Users who are viewing this thread

Top