FiiO X7 Mk II 2GB RAM + 64GB ROM + ESS9028 PRO + Balanced + DSD + BT 4.1 aptX + Dual mSD + Dual Band WiFi + Opt Out
post-14691159
Post #5,148 of 6,073

tjl5709

100+ Head-Fier
Joined
Nov 28, 2007
Messages
322
Reaction score
132
Location
S.E. Michigan
Joined
Nov 28, 2007
Location
S.E. Michigan
Posts
322
Likes
132
Based on the comments about the beta that is being evaluated, it sounds like they are still a ways out.
 
     Share This Post       
post-14693110
Post #5,149 of 6,073

jprenaud78

Head-Fier
Joined
Oct 31, 2018
Messages
90
Reaction score
25
Location
France
Joined
Oct 31, 2018
Location
France
Posts
90
Likes
25
     Share This Post       
post-14693173
Post #5,150 of 6,073

tjl5709

100+ Head-Fier
Joined
Nov 28, 2007
Messages
322
Reaction score
132
Location
S.E. Michigan
Joined
Nov 28, 2007
Location
S.E. Michigan
Posts
322
Likes
132
     Share This Post       
post-14693278
Post #5,151 of 6,073

SoundSquare

100+ Head-Fier
Joined
Jan 5, 2014
Messages
351
Reaction score
210
Location
Paris, France
Joined
Jan 5, 2014
Location
Paris, France
Posts
351
Likes
210
Does anyone want to chime in on their experience with this service?
don't waste any second trying this, it's based on an old firmware, i tried it months agon, it's not more stable and doesn't add anything actually. It will just prevent you from installing future updates.
 
     Share This Post       
  • Like
Reactions: Brooko
post-14697071
Post #5,155 of 6,073

Paulo Abreu

1000+ Head-Fier
Joined
Feb 17, 2016
Messages
1,246
Reaction score
588
Location
Madeira Island, Portugal
Joined
Feb 17, 2016
Location
Madeira Island, Portugal
Posts
1,246
Likes
588
After this question , total silent for 2 days.
As far as I know head-fi.org its not an official response/support channel for FiiO. Maybe you placed the same question to their marketing team?
Even so, this is the kind of question they may not be willing to answer, so a silent for 2 days (or forever) is perfectly normal.

My 2 cents
 
Last edited:
     Share This Post       
post-14697417
Post #5,156 of 6,073

jmac1516

100+ Head-Fier
Joined
Nov 5, 2010
Messages
180
Reaction score
91
Location
Chicago
Joined
Nov 5, 2010
Location
Chicago
Posts
180
Likes
91
As far as I know head-fi.org its not an official response/support channel for FiiO. Maybe you placed the same question to their marketing team?
Even so, this is the kind of question they may not be willing to answer, so a silent for 2 days (or forever) is perfectly normal.

My 2 cents
Completely agree. Fiio has no reason or obligation to answer this question here or anywhere. They will likely tell you that they are working on future products and/or product technology but will not communicate estimated timing until official launch.
 
     Share This Post       
post-14704652
Post #5,157 of 6,073

Ken G

100+ Head-Fier
Joined
Apr 27, 2017
Messages
333
Reaction score
234
Location
Phoenix, AZ
Joined
Apr 27, 2017
Location
Phoenix, AZ
Posts
333
Likes
234
Has anyone else tried Tidal after the latest update (with MQA integration)? Tidal gave me nothing but pure distortion for all MQA and non-MQA songs I tried to play. Even the tracks that I had downloaded a while ago to the device were heavily distorted. Tidal is now useless for me on the X7 Mk II. Anyone else having the same issues?
 
     Share This Post       
post-14704687
Post #5,158 of 6,073

BobSmith8901

100+ Head-Fier
Joined
May 5, 2015
Messages
314
Reaction score
123
Joined
May 5, 2015
Posts
314
Likes
123
Has anyone else tried Tidal after the latest update (with MQA integration)? Tidal gave me nothing but pure distortion for all MQA and non-MQA songs I tried to play. Even the tracks that I had downloaded a while ago to the device were heavily distorted. Tidal is now useless for me on the X7 Mk II. Anyone else having the same issues?

I have had the same issue on my X5III when I upgraded the app to 2.11 (MQA capable) See my posts:

https://www.head-fi.org/threads/tidal-masters-mqa-appreciation-thread.838888/page-32

https://www.head-fi.org/threads/fii...xd-dts-android-dual-card-slot.828402/page-949

Same exact problem. I ended up uninstalling 2.11 and reinstalling 2.10. Back to normal (but obviously no MQA in the app).

Also sent Tidal support an e-mail and they opened a ticket. Must be some factor that the X7 and X5 share.
 
Last edited:
     Share This Post       
post-14705646
Post #5,159 of 6,073

Double C

100+ Head-Fier
Joined
May 17, 2009
Messages
234
Reaction score
82
Joined
May 17, 2009
Posts
234
Likes
82
Has anyone else tried Tidal after the latest update (with MQA integration)? Tidal gave me nothing but pure distortion for all MQA and non-MQA songs I tried to play. Even the tracks that I had downloaded a while ago to the device were heavily distorted. Tidal is now useless for me on the X7 Mk II. Anyone else having the same issues?
I am having the same issue on Fiio X7 Mk I
 
     Share This Post       
post-14706742
Post #5,160 of 6,073

BobSmith8901

100+ Head-Fier
Joined
May 5, 2015
Messages
314
Reaction score
123
Joined
May 5, 2015
Posts
314
Likes
123
I am having the same issue on Fiio X7 Mk I
New Tidal Android version 2.11 (released today 8 Jan) fixed the distortion issue w/my X5III--Masters and Hi Fi all running normally now. I would imagine the X7's might be fixed too.
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 2, Guests: 3)

Top