1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Fiio X5iii Custom Kernel and Scripts | 2016MHz CPU | 20% RAM increase | Undervolting | New DAC drivers | and much more

Discussion in 'Portable Source Gear' started by jkbuha, May 3, 2019.
First
 
Back
1 2 3
5 6 7 8 9 10 11 12 13 14
Next
 
Last
  1. jkbuha
    Doesn't sound like it's kernel related. The bootloader (which has been left untouched) can be quite temperamental, and it sounds like the charging module decided to power off the unit for whatever reason (happened to me a couple of times). In that case I just unplug and replug the charger and the unit continues charging normally.
     
  2. TiborG
    It only happens to me when I use USB output to DAC. After 3 repetitions of this shock I'm not trying it anymore. I had to let the battery discharge up to 0%. I use kernel 3.1.1 speed 1704 No problem. I did not measure battery consumption, but I think it is better endurance
     
  3. shiro75fr
    Hi, i heard a lot of good things about your Kernel, i am trying to install it in my X5rd from my mac but this is crazy complicated for me. Does exist a tutorial who could help me to enjoy it ?
     
  4. MinnieOne
    jkbuha likes this.
  5. MinnieOne
    This was the first time I ever used Bluetooth with the FIIO, thought it might be related somehow. I tried unplugging several times. We shall see, I was just trying to find anything that might be different from past usage. Downgraded to slowest Kernel setting, will see what happens! Thanks.

    Thinking everything about the player is temperamental and you fixed a lot of it.
     
    jkbuha likes this.
  6. jkbuha
    Bluetooth radio is patchy and very temperamental. I'm not tampering with that code until I have a weeks supply of caffeine/codeine/single-malt.

    Version 3.2 is in final testing and will be released tomorrow, which introduces a new power saving mode (ACPI S0), RCU support and additional kernel modules that will extend performance as well as battery life. And more of prispewnic's magic scripts of course...
     
    TiborG and xnuthecaveman like this.
  7. shiro75fr
  8. WitzyZed
    It’s been a while since I managed it on my mac, I was lucky enough to have a roommate with a windows pc, but here’s what I did (if memory serves)
    Working around the instructions from fidelizer’s website you can install homebrew and rkflashtool:
    http://www.fidelizer-audio.com/flashing-fidelizer-purist-rom-firmware-on-mac-linux-guide/
    &
    http://www.fidelizer-audio.com/fiio-x5iii-purist-rom-version-1-2-4-released/
    they link to the fiio’s firmware upgrade tool in the second link. this will contain a stock FW 1.2.1 update.img so if you run into any irrecoverable situations before can even make a backup in TWRP you’re going to need to use the steps from the first link, but using the update.img from the second to get back to a fresh base. hopefully you won’t need to.

    but anyway the first link and the terminal commands (terminal app found in applications folder under utilities) to install rkflashtool are what’s most necessary.

    You'll need to install command line tools in mac os x: http://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/

    then install android debug bridge (ADB) using option 1 found here: https://stackoverflow.com/questions/31374085/installing-adb-on-macos

    then follow fidelizer instructions for rkflashtool

    There are two things using rkflashtool that need to be moved to device, (jkbuha if these are out of date please chime in), boot.img from this zip
    http://www.mediafire.com/file/wjqivdd2y7pbnl2/boot.zip/file and the TWRP_recovery.img in this zip https://androidfilehost.com/?fid=1322778262903998941.

    Before you power off your device I’d enable developer options in your X5iii, under about device tap on build several times to enable them, and under developer options enable USB debugging.

    You connect your player in powered off state to usb connection with your mac, while holding down the previous track rocker. In terminal you can try two commands to see that your device is recognized.

    rkflashtool v
    rkflashtool n

    so you type the below command and after the arrow (with a space after it), I want you to drag the TWRP_recovery.img into the terminal window and then hit enter.

    rkflashtool w recovery <

    once that finishes do the below command but with the boot.img file being dragged into the terminal window and hit enter

    rkflashtool w boot <

    you can then type following command then enter

    rkflashtool b

    to reboot your device. if it boots properly, and still connected to usb, in terminal type below command then enter

    adb reboot recovery

    and hopefully you should boot into recovery.

    you can then move the latest kernel to your device and install/flash the zip in TWRP (as described by the general tutorial/instructions provided by jkbuha)
     
    Last edited: Jul 31, 2019
    shiro75fr likes this.
  9. TiborG
    I only tested the soundFx from M11 for 2 days. First a wow effect, after a long review, flew out of the libreverbwrapper.so player, and finally the entire soundfx directory. Terrible highlighted reverb - up ringing in the ears, without libreverbwrapper a little better. Younger ears will certainly distinguish it sooner. I think the authors are trying to improve the slightly dull sound of AK4493 (On my Topping DX3 is also AK4493). Now I enjoy the natural delicious sound and the soundfx directory remains soundfx.bak. Even my BD DT 880 says I'm the only right way. And Airplay finally works under Mac OS Mojave !!
     
  10. WitzyZed
    I myself wasn’t able to get AirPlay working on El Capitan (I’ve got an iMac from 2007 still kicking), but it does work on iOS 12.2, much to my surprise.
     
  11. TiborG
    This will be because I have a hand-tuned hackintosh on Intel NUC (haha). Basically, it's only good to kill a battery, max 44.1 kHz, that's nothing.
    The only 100% stream from PC is Foobar UPNP plugin. Flash library update, instant response and playback. Even JRiver DLNA is not as fast and stable.
    Interestingly, on Sierra High it stammered and eventually dwindled after a few minutes. On Mojave no ..
     
  12. shiro75fr
    Thanks a LOT for your help !!! it resolved my problem and now i can enjoy this new kernel and give a new life to my Fiio !
     
    TiborG and WitzyZed like this.
  13. WitzyZed
    109144DF-171A-40A7-85BE-180A3B7A1D2E.jpeg

    I’m glad you sorted it out !
     
  14. TiborG
    Just out of curiosity I tried flash stock FiiO 1.2.1 after MAC OS Mojave by manual from Fidelizer page using terminal, rkflashtool and works perfectly. I did a flash complete of the Image folder including recovery.img and misc.img and everything went smoothly. So it is not necessary to search for friends with Windows PC and finally I do not have to translate everything as a sound engineer before the concert.
     
  15. WitzyZed
    how do you think I got the kernel working for myself months and months ago ? lol
    of course it works. obviously as tools came out to speed up the process with access to windows, there’s an easy choice if you have it.
     
    jkbuha likes this.
First
 
Back
1 2 3
5 6 7 8 9 10 11 12 13 14
Next
 
Last

Share This Page