1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Fiio X5iii Custom Kernel and Scripts | 2016MHz CPU | 20% RAM increase | Undervolting | New DAC drivers | and much more

Discussion in 'Portable Source Gear' started by jkbuha, May 3, 2019.
First
 
Back
16 17 18 19 20 21 22 23 24 25
  1. prispewnic
    I could argue with that, but I guess I won't :) If it matters so much to a person, who are we to take away that right? Anyway, I want to thank @techguy777 for such an intensive monologue, as it helps to promote this thread.

    Dear @techguy777 . All our with jkbuha work, on the custom kernel is documented on the guithab https://github.com/jkbuha/FiiO_Kernel_Android. You can download all the source code and compare it to the source code that was made freely available by FiiO. FiiO itself has made almost no changes to the kernel. The foundation was laid by the community of GNU\Linux and RockChip. Based on this, we began our development and modification of the code. All of the installer scripts, etc., were also written in a fairly simple way, without using complex forms, so that everyone could adapt them to their needs.

    I will also repeat myself for the last time. If you are not satisfied with our work, you have the right not to use our product. We don't insist that the FiiO X5-3 must be paired with our custom kernel. Each user must accept the user agreement before using the Custom Kernel on FiiO X5-3. I'm also very much asking you not to overstep the boundaries of communication and to observe the standards of decency.

    The last thing I want to remind everybody about: This thread is not about V4A; Magisk; MicroGapps; Neutron e.t.c., but about the custom kernel we made. Personally, I like the fact that a lot of people are interested in technology and music, but I would be very grateful if all the dialogues, which do not concern the custom kernel directly, would be held outside of the topic. Thank you all for understanding.
     
    Knuubs, ghosthost, jkbuha and 2 others like this.
  2. Peter Puget
    Grrr....still having some issues installing the new kernel. That said it did work once for me so I am wondering if I am just making a silly error somewhere. Also, wiping the device and using the fiio flashing tool is relatively easy.

    Here’s what I think I’ve done:

    1- Used fiio tool to install 1.2.3
    2 - used android tool.exe to install TWRP and fixed permissions
    3 - used TWRP to install supersu I installed from internal memory not an Sd card.
    4- turned off logging in supersu
    5- rebooted into TWRP and installed 3.41 kernel. Installed lowest speed.

    Everything looked good however the process hung up during reboot. Waiting 15-20 minutes and the initial reboot was not successful. Tried the entire process several times.

    Without looking over my shoulder while I was doing the install I know it’s hard to offer advice but if you have any suggestions as to what I could be missing I’d appreciated the advice.
     
  3. prispewnic
    Hi :) What frequency did you choose when you installed the kernel? Does your device hang when using a 1.4 GHz frequency?

    You don't have to wait 15-20 minutes for the first time after the kernel is installed. I recommend that you restart the system as soon as you receive the pop-up notification "KERNEL 3.4 : PLEASE REBOOT DEVICE"".
     
    Last edited: Dec 18, 2019
  4. Peter Puget

    I chose the 1.4 frequency. I am not getting as far as the “please reboot” notice - the initial reboot is hanging up so that notice never appears.
     
  5. WitzyZed
    (Speaking from experience not expertise)

    microUSB Connection disconnected before hitting finish in the installer?

    Do you get to the “Optimizing Apps ## of ##” step during the first boot after hitting finish in kernel installer?

    If you didn’t do a factory data reset after doing the 1.2.3 firmware wipe, put a pin in that potentially. There’s such a large number of excess diagnostic apps, I wonder if that’s doing it in somehow?

    Also any microSD cards maybe take out so any media scanner service processes don’t hang it either?
     
    Last edited: Dec 18, 2019
  6. SGarfinkle
    Just to add a note of positivity - I'm a new X5-III user and I really appreciate all the hard work that's gone into both the bootloader and kernel hacks!
     
    jkbuha and WitzyZed like this.
  7. Peter Puget
    Well long story short - it was the Microsd cards causing my problem. I have two cards only one was exfat. New firmware worked fine with ether no cards or the one exfat card. Reformatted the bad card and everything is good to go. For almost a day at 1.7 speed. Thanks again for the firmware and to those who offered solutions.
     
    WitzyZed likes this.
  8. glucio
    Hello guys!
    I would like to say thank you to developers for making my player amazing again! I runs so smooth now. There is just one strange thing I am experiencing with Tidal app. When I want to stream/download in "Master" (the highest quality), the audio is choppy. I am running 1.2.5 stock firmware with custom kernel patch v3.41 (1406 Mhz, interface boost enabled, disabled applications except Google,the rest is default). Do you know where might be the problem? I think that my previous firmware without custom kernel (1.1.7) was able to play the Master quality properly. Thank you in advance!
     
    WitzyZed likes this.
  9. jkbuha
    Unfortunately that’s a known bug that’s crept into 3.4x that prispewnic and I are aware of and will be fixed on the next build. The trigger conditions are not fully known yet but 3.32 works fine with tidal MQ. Also coming straight from vanilla to 3.41 sometimes fixes the issue so it could be residual related.
     
    WitzyZed likes this.
  10. WitzyZed
    Doesn't have all the library features / access to downloaded music that official tidal app has, but UAPP (USB Audio Player Pro) on 3.41 custom kernel streams Tidal MQ without chops.

    -edit- my buddy with player on 3.41 said he only experienced chops when playing already downloaded MQ via tidal app. but no chops when streaming MQ in either tidal or UAPP.
     
    Last edited: Dec 30, 2019
    jkbuha likes this.
  11. glucio
    Hello. Thank you for your reply. This is strange. I experience chops when I stream or download. This apparently did not happen when being on official stock ROM/kernel (build 1.1.7)

    As far as I understand I either buy UAPP or need to revert to original stock in order to run Tidal MQ properly?

    Writing my specs again:
    FiiO X5 (3rd gen)
    Android version: 5.1.1
    Kernel version: 3.0.101+ jkbuha@prispewnic #34
    Build number: 1.2.5

    Thank you!
     
  12. jkbuha
    The issue happens on both streaming and downloaded MQA. But only on 3.4x. In fact if you flash kernel 3.32 or fresh install 3.4x on vanilla the issue goes away.

    We had marked this bug down as low priority as we have not received any feedback so far (only 2 on this forum and 1 on 4pda) but it will get fixed in the next release.
     
  13. glucio
    Hello. Thank you for your message. I can try flashing kernel v3.32 with TWRP (http://bit.ly/FiiOX5iiiV332). I am unfortunately not familiar with "fresh install on vanilla" in case I would like to try the newest version of the kernel. WHere I can find the guide for this process, please? Thank you in advance!

    EDIT: I am on 3.32 now. It seems choppy audio went away, but after circa one minute, Tidal app crashes :/ (the only change I have made since the last kernel update was the 1706Mhz - went there from 1406 Mhz. Does anyone have an idea what could be the source of this problem? It still keeps crashing Thank you!

    EDIT2: Ok. Looks the crashing issue went away after wiping cache in TWRP and reinstalling the app.
     
    Last edited: Dec 30, 2019
First
 
Back
16 17 18 19 20 21 22 23 24 25

Share This Page