FiiO X3 mod - AD8397 to AD8620

  1. v4ever16
    I've bought the new component (the exact same model) and we've soldered it in the right direction.
    Unfortunately, when I play a song and I plug the headphones, I can hear "TAC" sound from the player and then, after maybe 2 seconds, another from the headphones, and it gives me the message: "Output error Please reinsert earphones".
    I specify that the music works from the LINE OUT.
     
  2. v4ever16
    I think that the first TAC is the relay.
    But I cannot understand the second. Maybe is there some short-circuit?
     
  3. ClieOS Contributor
    There is only one relay inside X3 so what you are hearing is the opening and closing of the same relay. My guess is, there is either no power / signal on of the the channel due to unknown damage to the voltage supply rail (as the headphone-out opamp is only half powered), or your opamp has a cold solder join (less likely). The worst case is there might be some high DC offset (which the relay has protected you from). The opamp buffer on the line-out actually can work with a single supply rail so it might not get affected by the problem on the supply rail. There is no easy way for me to tell which is which though.
     
    v4ever16 likes this.
  4. v4ever16
    Many thanks ClieOS.
    You have been clear, now I can't do anything else. Now I'm trying to send it to Fiio for a reparation.
     
  5. Benno
     
    Hi ClieOS,
    Could you help me to locate this AD8692 opamp?
    Thanks,
    Benno
     
  6. ClieOS Contributor
     
    It is on the front of the PCB, right next to the buttons.
     
  7. Benno
    Thanks for Clieos, Is this the spot you ment?
    I only see the ad8397 here, but i'm looking for the line-out buffer opamp, the ad8692.
     
    Sorry for my noobness. I made pictures but i'm not permitted to attach them.
     
  8. AudioCats
    ^^^  ad8692 is on the other side of the board, (below the press-switches).
     
     
     
     
    Thanks to this thread, I now own a X3 and of course, the stock chip has now been replaced (never was very impressed with the 8397 anyway.....). It now sports an AD8599 for headphone-out, the sound is a bit darker and more "emotionally involving", with about enough power for driving my EarSonic SM3's.
     
    But neither the 8397 nor the 8599 has enough juice to run my Fostex T50rp.  I think there is enough (barely) room on the board to add a pair of BUF634's next to the AD8599, that should provide some more firepower, hopefully enough to drive the small ortho's.  so....I have a pair of SOIC BUF634 coming [​IMG]
     
  9. DingoSmuggler
    The x3 at stock will be volt limited into the T50rp 50 ohm load, not current limited. If you need more oomph for your orthos, you'll need an external amp with some voltage gain.
     
  10. Benno
    Thanks AudioCats for clarifying this! 
     
  11. AudioCats
    Got the BUF634 buffers installed the other day.
     
     
    IMGP2974.jpg
     
    Both BUF's are installed up-side-down, each has two pins soldered to the AD8599 pins, so they are mounted quite securely machanically (the SOIC-8 package doesn't weight anything, with two direct attachment points they are not going any where ). All jumper wires have teflon insulation, I think power wires (the yellow and grey) are 24awg and the white signal wires are 30awg.
     
    The whole mod took a lot longer than I expected, about 30 minutes on figuring-out/planning the mod and another 1.5hr for the actual operation. If I have to do it again, I suspect it will still take at least 45 minutes since everything has to be done quite carefully, including folding some of the buf634 leads backwards. A magnifier of some kind is an absolute must if one want to do the mod, ideally you should have access to a stereo microscope (which I did use, very helpful during the soldering).
     
    I took a lot of step-by-step photo's thinking I mgiht want to do a tutorial, but at this point I don't think they are needed. I have to admit I don't like the sound, at least for now:
    -- with sensitive phones (such as my EarSonic SM3, which sounded quite groovy driven by just the AD8599), the sound seems to be harder and missing the "feel" of music (missing low level details, I suspect), and it is a bit too bright....and this is with SM3 which is a supposedly dark-sounding IEM....
    --for the more power hungry phones such as T50rp, the buffered circuit has a bit more power than before,  the bass for T50rp is now quite ok, but the sound has a certain brightness/hardness to it. And it might be less detailed (don't remember how detailed the T50rp was with the original AD8397, it was a while back and all I remembered was thinking the T50rp's bass sounded too soft with the stock X3; AD8599 without buffer couldn't run the T50rp well either ).
     
    Maybe the new buf's just need more burn-in. [​IMG][​IMG]  The X3 is now playing in repeat mode with charger plugged-in, I will let it run non-stop for the next 2~3 days and then take another listen.
     
    But I suspect the bright/hardness of the buffered sound is due to the x3 power supply can not keep up with the now much larger power demand. Maybe I will have to add at least some larger power caps. Not sure where to mount them yet.
     
    bellor likes this.
  12. AudioCats
    ran the x3 for about 20 hours, off and on. The sound mellowed down a little but the irritating brightness was still very much there. Sounded ok with my Fostex T20 (the original V1 ), but that was about it.
     
    So I paralleled 400uf reservoir caps to each stock power cap (stock caps are 100uf), and gave it a listen.
     
    IMGP2976.jpg
     
    With the added reservoir caps in place, the sound got better right away, more or less back to the AD8599's dark and intimate sound signature, but with more power to support the bass. It is full and engaging, though a little rounded (comparing to the X3 line-out driving a desktop amp) , I guess some of the micro-details are still missing . But the rounded-ness in a mobile player doesn't bother me . If I want all the micro-details I would use the X3 line-out to feed a desktop amp.
     
    The next step is to relocate the reservoir caps to area around the 3.5mm jacks and the white relay. The good news is, there is plenty of room available, if I stick to using the relatively large low-ESR 16v tantalum caps (like the ones in this experiment), there is room for adding 1000 uf per rail. If using the same kind of tiny cap like the stock caps on the board, which is about 1/4 the size , I suppose one can add 2000~3000 uf per rail very easily (but I suspect those are "not so low-ESR", not sure how they would affect the sound in large value). The question now is how much is really needed here. The larger the reservoirs, the more bouncy the bass but it can also soften the sound too much if over done, I guess 300~500uf per rail of fast/low-ESR caps might be a good balance.  
     
     
     
    A note about the battery life with the buffer mod
    I did a run-time test during the burn-in, both to see how long the battery will last with the mod in place, and to see if there is any undetected oscillation going on (the oscillation might not be easily audible but it would cause extra current drain if it is there) . The buffered X3 was driving the Fostex T50rp at volume 100 (which is quite loud, my normal listening would be at 80 and background listening at 60 or less). Starting from a full charge, the battery indicator dropped down to the last bar at around 10.5hr mark. There was still one bar left so I suspect it could have played for another hour or so, but I didn't want to drain the battery dry so I ended there test there. Looks like the BUF634 buffers did not cause any major increase in battery power consumption.
     
    bellor and Mmet like this.
  13. AudioCats
    got lazy and ended up only adding 320uf per rail. (220uf + 100uf, 16v low-ESR tantalum caps). Wire used is teflon insulated 22 awg. Clear heatshrink to cover the caps.
     
    The sound is somewhat brighter than in the experiment above, probably because of the longer wire length added unwanted resistances. Or maybe 220uf caps don't sound the same as 100uf, not sure. Still sounding quite good, can drive all my dynamic phones (600 ohms Beyer 990 and AKG K240, Fostex T20v1/T50rp, and Earsonic SM3) to satisfactory. Good enough for me, for now.
     
     
    IMGP2977.jpg
     
    bellor and Mmet like this.
  14. imackler
    @ClieOS Any thoughts how the X3ii compare to the X3 w/ the AD8620? (Sorry if I missed them any comparisons in other threads...) 
     
  15. ClieOS Contributor
     
    Here:
     
     

Share This Page