1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Feliks-Audio EUFORIA - A Wolf in "Sheep's" Clothing...

Discussion in 'Headphone Amps (full-size)' started by hypnos1, Jan 9, 2017.
First
 
Back
482 483 484 485 486 487 488 489 490 491
493 494 495 496 497 498 499 500 501 502
Next
 
Last
  1. hypnos1
    For sure @connieflyer ...anything Chip Davis does is fine by me - a true master of the 'New Age' genre. And the 'Mannheim Steamroller' series is certainly one to cherish lol :smile_phones::smile_phones:...CJ
    ps. And the quality of recording is second to none...:ksc75smile:
     
    Last edited: Nov 22, 2019
  2. hypnos1
    Let's hope so bt...but with all our tubes being brand new, all readings are likely to be quite high lol (so a mixed blessing, it looks like :smile_phones::triportsad:). Fingers crossed nonetheless :fingers_crossed::fingers_crossed:.

    Hi S. Interesting that in your 300 ohm Atticus the hum is louder than the 600 ohm Beyers...which would indicate impedance differences are not such an obvious factor after all lol, given my experience with pre amp out duties and my 32 ohm Meze Empyreans...the former totally silent, with infinitesimal hum in the Empys.

    Ah well, perhaps the moral of the tale is...go for the Empyreans lol!! :wink:...they sure do love Euforia with the KT combo especially...:beyersmile:.
     
    Scutey likes this.
  3. Scutey
    Yes I thought that too, re the Empyreans I'd love to go for a pair, problem is my wallet wouldn't!, maybe when I win the lottery! :ksc75smile:.
     
  4. LoryWiv
    Quick question: I was rolling my 7581A's back into Elise and when i was placing them into adapters for 6AS7G socket, the plastic guide pin center portion of one of the 7581A broke of in the adapter. I was able to remove it and have placed the tube into the adapter with correct orientation, seems to be working normally but curious if this could pose harm to the tube or amp in the longer term. :triportsad: Hopefully not!
     
  5. hypnos1
    Hi S. All I can say (seriously!) is get saving lol...they're worth every penny, despite my initial hesitance in spending that kind of money on headphones...CHEERS!...CJ
     
    Scutey likes this.
  6. Scutey
    I'd better get saving then, or I could just try and sell the missus!.
     
  7. Scutey
    Actually I've done the same thing with one those too, also have a couple others with broken guide pins and they work fine, and as far as I know there should Not be any long term concerns either.
     
  8. hypnos1
    Hi LW...no problem at all. And well done on getting the correct orientation lol! Sometimes you can see where the locating protrusion was, otherwise it's not so easy - but a cheap multi-volt DC charger/adapter (1000mA) set at 6/7V will soon trace the heater pins.
     
  9. hypnos1
    I keep threatening to put mine (the missus, not the Empys!!) on ebay...but can't think what reserve to put lol!!...(daren't let her know it's too low :astonished::wink:)...CJ
     
    Last edited: Nov 23, 2019
    Scutey likes this.
  10. barontan2418
    I did exactly the same when fitting KT66. Makes no difference just take care when aligning tube.
     
  11. mordy
    These things happen. For me the easiest way is to stick on a little piece of red tape indicating the location of the ridge on the guide pin. As mentioned, if you look carefully at the base, you can almost always see a little notch where that ridge was located.
    [​IMG]
    If you really are worried about the right orientation, you can buy octal rings with a guide pin and attach to the tube.
    https://www.ebay.com/itm/6-Pcs-Vacu...115670?hash=item236ccb4316:g:QtIAAOSwacdZbjxB
    [​IMG]
    [​IMG]
     
    hypnos1 likes this.
  12. LoryWiv

    Thanks for all the help on the broken guide pin. I do have the adapters fit correctly and plan to leave them securedto eliminate futre mishaps. If I do remove them, the tips above will be front of mind! Thanks again.
     
    Last edited: Nov 24, 2019
  13. Scutey
    Lol yes, think mine would be more insulted by a low reserve than the thought of selling her!.
     
  14. hypnos1
    Ah yes, mon ami...discretion certainly is the better part of valour lol! :wink:...(and safer!! :L3000:).

    Anyway folks, back to more serious (?!!) matters, I'm happy to report that the slight hum from my setup with the KT66/88 combo - as some of you also seem to have - is gradually diminishing from my more-prone HD650s, and not noticeable with my Empyreans now. Hopefully y'all will experience the same with a good bit more burn in. And gain comfort also from the fact that my mesh plate Valvo EL11s had the exact same very slight hum, and 2 years' constant use caused no harm to the amp whatsoever...:smile_phones:.

    And I found some interesting info that might just give a clue as to the esteemed ancestry of our reissue Gold Lion KT88s (supposedly made to the same spec), along with a current asking price for an original...:astonished:!!!...

    Capture Gold Lion spec 2.PNG
    Capture Gold Lion Tube.PNG

    No doubt the level of quality control can't quite match the original, but reports that the new production tubes aren't too far off the NOS would certainly explain the superlative results I'm now getting from my own 88s...especially when driven by the 66s. And their price is much more to my liking lol! :ksc75smile:...CHEERS!...CJ
     
  15. OctavianH
First
 
Back
482 483 484 485 486 487 488 489 490 491
493 494 495 496 497 498 499 500 501 502
Next
 
Last

Share This Page