E-MU 0202 problems!!!
Mar 16, 2008 at 2:55 AM Thread Starter Post #1 of 7


New Head-Fier
Dec 29, 2006
Hey folks,

So I picked up a snazzy E-MU 0202 for my laptop, so that I can power my nice HD580 effectively. It sounds GREAT, and I'm a big fan.

However, it's been doing some crazy stuff recently. I'll be surfing the web with Foobar open (This happens with DirectSound or ASIO output, at 44.1 KHz our resampled to 176,400Hz), and it will occasionally skip. Sometimes once every minute, sometimes every few seconds. It's INFURIATING!!! Ideas?


Mar 16, 2008 at 6:33 AM Post #2 of 7
Try by increasing latency buffers on ASIO Control Panel ... to 10-50ms and on foobar, try if changing buffer length has any effect.

Amyway, check your system with DPC Latency Checker and if there's PCI based graphis ... drop the PCI latency for graphics adapter to 64 with PCI Latency Tool. You find both utilities through google quite easy by using utility names as searching criteria.

Mar 16, 2008 at 1:38 PM Post #3 of 7
Usually.......laptop + surfing = high probability of a wireless network card in use, is that right?

Wireless networking seems to be the biggest cause of problems with the 0202 USB/0404 USB.
Mar 18, 2008 at 8:24 PM Post #5 of 7
1) Yes, I am using wireless.Turning it off has basically fixed the issue. Wow. That _really_ sucks!!! Hopefully I can find some way to make the two co-exist.

2) I have tried with and without resampling. This is not a CPU load related issue - I have a 1.8 GHz Core 2 Duo

3) DirectSound seems to work much better than ASIO at the moment. For one, each time I connect the 0202, I have to re-make the ASIO virtual device (annoying). For two, it skips _horrrrribly_. I have tried adjusting the ASIO buffer size between 10 and 50, and no matter what I set it to, I get massive, constant skipping. If I increase the foobar buffer (to 2000ms let's say) - things are fine, until that runs out (I can count 2 seconds). Then it's constant skipping death. Sometimes it's so bad that playback fails! Kernel streaming does not seem to work no matter how I configure it. Again, turning the wireless off mostly fixes the issue, but that's not good enough for now!

4) DPC Latency Checker shows that most of the time things are good, but I get huge red spikes up to 16,000 us occasionally - and these coincide with the skipping audio (big surprise...). This _sucks_. I tried changing the latency for my built in PCie graphics controller to 64, but it didn't help.

The really wierd thing is that I'd been using this thing for a week perfectly in my office, without a single distortion. Then I take the setup on the road, and it all goes to hell! I'm flirting with the possibility of having a bad 0202. The package was half-open at Fry's electronics, which is NEVER a good sign, but it was their last one in stock! I still have the receipt thankfully.

Now that I think about it though, I always turn the wireless off at work, since we don't have a good WiFi network. I'm always plugged into a docking station there. Man.

It's a Dell D630 with the built in Dell 1490 dual band Wireless adapter. Does anyone know of a good Cardbus or Mini PCI wireless adapter that doesn't totally pwn your latency? This is REALLY a downer!

Thanks for your input!

Mar 18, 2008 at 9:30 PM Post #6 of 7
I don't know how the wireless card would be identified in PCI Latency Tool, but dropping it down might also work--maybe jiiteepee has some guidance on that.

Most of us who use Foobar and ASIO have reverted to v0.8.3. For some reason, the ASIO implementation in v0.9.x has issues.

FWIW, the fact that it works well when you disable the WiFi card makes me conclude the 0202 USB is fine, because your problem is exactly what some others have experienced.

Any chance that Dell has a driver update for your adapter? Any user comments on Dell's tech forums about functionality issues with other USB devices (audio or even non-audio) that were traced back to the WiFi adapter?
Jul 28, 2008 at 11:50 PM Post #7 of 7
Damn, I'm getting the same crap on my Dell Vostro 200 desktop at work with the EMU0202 USB; this sucks!

I'm not even using wireless. Any ideas of what to do?

Looks like the latency on my system is terrible when using ASIO - used this to check: http://www.thesycon.de/deu/latency_check.shtml

Found the culprit, crappy network card drivers. Will update now.

Users who are viewing this thread