1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

DX220 A new view to your music. * Latest Firmware: 1.13.202 Local * Link for User Guide 1st Page. AMP9 Now available! And DC01.

Discussion in 'Portable Source Gear' started by Paul - iBasso, Jan 23, 2019.
First
 
Back
431 432 433 434 435 436 437 438 439 440
442 443 444 445 446 447 448 449 450 451
Next
 
Last
  1. icefalkon
    AMP8 will definitely drive the Diana's. I tried them at the AXPONA audio show.
     
    arijitroy2 likes this.
  2. Pictograms
    How was the synergy? I don’t have any other balanced gear so I have avoided the plunge. Although how did you find the Diana comfort... I’ve been finding that has a huge impact on sound impressions
     
  3. icefalkon
    The Diana sounded great on the DX220 with AMP8. As for comfort, they were VERY comfortable. It's time to take the plunge! lol
     
    Pictograms likes this.
  4. Pictograms
    I was hoping you wouldn’t say that... thanks
     
    icefalkon likes this.
  5. ExpatinJapan
    478C9931-D115-4DB2-A57E-9234C13E03F8.jpeg
     
    fuhransahis, fokta and Pictograms like this.
  6. icefalkon
    Does anyone on here also have the Ether2 headphones? I'm using the leather pads and am curious about whether the velour pads make it sound any different.
     
  7. fokta
    During a small Gathering a couple of weeks ago, There was a DX220 with Purist and also Lurker0...
    for installation, Purist first dan then Lurker0 add on.
    Based on what I see, Lurker0 add on is much simpler.
     
  8. singleended5863
    Yeah Lurker is simple but I have never got that and keeps failing me. I gave up! :slight_frown:
     
  9. fokta
    @Lurker0 a little help over here...
     
  10. singleended5863
    He has helped me couple times but somehow it failed every time I update the add on.
     
  11. fokta
    hmm... quite unfortunately for you.. well its time to move on then... There's Mango OS for a start...
     
  12. singleended5863
    However, I tried the Fidelizer’s Purist ROM and it failed again :angry: since I need only Google Play to install the streaming music app which does recently work after installing from APKpure but it shows warning sign every time I log in.
     
  13. Hiltonk
    Try using a 8Gb or 4GB uSD card and follow the below:
    1. download and install https://sourceforge.net/projects/win32diskimager/ on your PC
    2. download the latest Lurker Firmware updater ; https://github.com/Lurker00/DX220-F...DX220FirmwareUpdater/DX220FirmwareUpdater.zip
    3. unzip the DX220FirmwareUpdater.zip image to your desktop - this file is used to create the boot partition on the uSD card - it is not the firmware add-on - that comes later...
    3. run win32diskimager and write the DX220FirmwareUpdater.img file from your desktop to the uSD card

    If all went right , you should have SD-card labeled as DX220UPDATE, with the following content:
    • sd_boot_config.config
    • sdupdate.img
    • rksdfw.tag
    sdupdate.img is empty (0 bytes), and it is the placeholder for the real firmware update image file. You now need to get the actual firmware and copy it to the uSD.

    Now you need to get the latest firmware add-on
    4. download the firmware add-on from https://github.com/Lurker00/DX220-F...ownload/v1.21/DX220-A8.1-L1.21b1-sdupdate.zip
    5. unzip the firmware to your desktop and copy sdupdate.img to the uSD card - overwrite the file that's there.

    6. Safely eject the uSD card from your computer
    7. ensure no USB cables are plugged into the DX220 and shut it down. (make sure it has a good charge of at least 20% or more)
    8. Insert the uSD card and power on the DX220 - it should now patch the firmware and tell you to turn off and remove the uSD card when it's finished. This should only take a minute or two.
    9. When told to do so on the screen - remove the uSD card are reboot your DX220.

    You should now be patched.
    You now need to follow the readme file that's included to register your device with Google for the Playstore to activate. You use the USB Audio App for this.
    "Uncertified device" problem
    ----------------------------
    To work around uncertified device problem, you have to register your device in Google.
    The registration page is here:

    https://www.google.com/android/uncertified/

    Please read below how to do it. Meanwhile, to stop the annoying notification, long tap on it
    in the status bar and turn it off there.

    To find out your Google Framework Services Android ID:
    ------------------------------------------------------
    1. Start "USB Audio" application.
    2. Open menu (3 dots at the right top corner) and select "Google Android ID".

    If your device has already assigned the ID, you'll see it on the screen. It is copied
    to the Android clipboard, so you may try to tap to the link, logon to Google account in
    the Chrome browser (NOT on the device! Tap the left button in the Chrome!)) and paste the ID
    for registration. Instead, you may use your computer to open the link and carefully type in
    all the 19 digits to register.

    If it does not show the android_id (19 digits), it means you haven't connected to Internet
    long enough for Google Services to create the ID.

    After registering, it may require to reboot, connect to WiFi and wait for some minutes,
    until the uncertified status becomes 5 (five). From now on, your device is registered
    and you are allowed to use Google Services.
    If you don't do this last step, Playstore will not work properly.

    Note these links are only relevant to apply to the current official version from iBasso and later future versions should use the latest Lurker mods.

    Goodluck! You are patching the firmware at your own risk. If you don't feel confident doing this then don't do it. :)
     
    Last edited: Jul 18, 2019
  14. gto88
    Man, that is quite some works.
    I have not received my dx220 yet, and have no chance to read through all posts, so
    May I ask what is this for?
     
  15. singleended5863
    When you get your DX220 make sure you have to update the new FW for your unit which can be downloaded and updated by WiFi.
    Now the next part you can see above that is Lurker0 add-on FW that I tried to update to my DX220 but I always got download failed. That is why I has been asking around but only @Hiktonk helping me with such details.
    The Lurker0 add-on is to help you get google play for some apps you wouldn’t able to use with APK pure cane with DX220. It is up to you if you want to use Lurker0 add-on.
     
First
 
Back
431 432 433 434 435 436 437 438 439 440
442 443 444 445 446 447 448 449 450 451
Next
 
Last

Share This Page