Chord Mojo DAC-amp ☆★►FAQ in 3rd post!◄★☆
post-12280406
Post #9,871 of 40,379

simonm

Head-Fier
Joined
Mar 26, 2007
Messages
94
Reaction score
59
Joined
Mar 26, 2007
Posts
94
Likes
59
Quote:
Has anybody found that the balls sometimes stick in place and won't click? The volume down ball is fine, it rotates without any force, but volume up and power are stiff and sometimes I need to rotate them with a little bit of force before they become clickable again.
 
My balls rotate freely and don't stick. lol  That's how they should be I presume.
 
If you have computer screen or lens cleaner try giving them a good clean and polish (with the unit off of course) and dry.  The manual says you can use Windex but that sounds a bit harsh (I'm protective of all my electronics).
 
If you still find they're sticky I think you should get it serviced or replaced.  You don't want the volume up ball to stick and blow out some nice earphones.
 
     Share This Post       
  • Like
Reactions: fluidz
post-12280505
Post #9,872 of 40,379

fluidz

100+ Head-Fier
Joined
Oct 12, 2011
Messages
304
Reaction score
47
Location
Uk
Joined
Oct 12, 2011
Location
Uk
Posts
304
Likes
47
   
My balls rotate freely and don't stick. lol  That's how they should be I presume.
 
If you have computer screen or lens cleaner try giving them a good clean and polish (with the unit off of course) and dry.  The manual says you can use Windex but that sounds a bit harsh (I'm protective of all my electronics).
 
If you still find they're sticky I think you should get it serviced or replaced.  You don't want the volume up ball to stick and blow out some nice earphones.
 
Thanks.  I used window cleaner on a cloth and now they're moving much more freely.
 
     Share This Post       
post-12280522
Post #9,873 of 40,379

yoyorast10

100+ Head-Fier
Joined
Jun 16, 2014
Messages
348
Reaction score
21
Joined
Jun 16, 2014
Posts
348
Likes
21
Is it normal that the volume down ball doesn't rotate as easily a the other balls?
 
Also, on the outside of the balls, it looks like there's dirt on it or something. Is this normal?
 
     Share This Post       
post-12280580
Post #9,874 of 40,379

Mojo ideas

John Franks
Sponsor: Chord Electronics
Joined
Oct 20, 2015
Messages
1,165
Reaction score
1,705
Joined
Oct 20, 2015
Posts
1,165
Likes
1,705
My balls rotate freely and don't stick. lol  That's how they should be I presume.


If you have computer screen or lens cleaner try giving them a good clean and polish (with the unit off of course) and dry.  The manual says you can use Windex but that sounds a bit harsh (I'm protective of all my electronics).

If you still find they're sticky I think you should get it serviced or replaced.  You don't want the volume up ball to stick and blow out some nice earphones.
Some time some foriegn material might get into the gap surrounding the ball. Try rotating the ball for a few minutes the ball should become free.
 
     Share This Post       
post-12280591
Post #9,875 of 40,379

howdy

Headphoneus Supremus
Joined
Dec 25, 2012
Messages
4,494
Reaction score
865
Location
Minnesota
Joined
Dec 25, 2012
Location
Minnesota
Posts
4,494
Likes
865
Some time some foriegn material might get into the gap surrounding the ball. Try rotating the ball for a few minutes the ball should become free.
 

Is there anything underneath the ball to restrict debris from getting in the internals?
 
     Share This Post       
post-12280628
Post #9,876 of 40,379

fluidz

100+ Head-Fier
Joined
Oct 12, 2011
Messages
304
Reaction score
47
Location
Uk
Joined
Oct 12, 2011
Location
Uk
Posts
304
Likes
47
With the included micro usb cable it's loose at the Mojo side and loses connection with my phone if the cable is nudged slightly up or down, only a gentle nudge is required to make it lose connection.  
 
I connected a couple of other micro usb cables which seem a bit better and require more of a nudge to break the connection but it still happens. 
 
Not ideal if strapping it to my phone.  Is anybody else experiencing this? Do I have a defective unit?
 
 
 
     Share This Post       
post-12280713
Post #9,877 of 40,379

Mojo ideas

John Franks
Sponsor: Chord Electronics
Joined
Oct 20, 2015
Messages
1,165
Reaction score
1,705
Joined
Oct 20, 2015
Posts
1,165
Likes
1,705
Some time some foriegn material might get into the gap surrounding the ball. Try rotating the ball for a few minutes the ball should become free.
 

Is there anything underneath the ball to restrict debris from getting in the internals?
The switches are sealed to IP67 standard
 
     Share This Post       
post-12280758
Post #9,879 of 40,379

nmatheis

Headphoneus Supremus
Joined
Dec 30, 2013
Messages
14,525
Reaction score
9,500
Joined
Dec 30, 2013
Posts
14,525
Likes
9,500
GreenBow: Interesting that you pointed out the 0.5 second mute isn't consistent. While I didn't notice that while using Mojo + iPhone during my week long audition period, I do find the same inconsistency in applying the 0.5 second mute applies to the Soundaware Esther DAP I just reviewed. The 0.5 second mute should only happen in that DAP when switching between resolution, but it sometimes occurs between songs with the same resolution. Not sure why. I just mention it because it sounds similar. Sorry if it's too OT.
 
     Share This Post       
post-12280789
Post #9,880 of 40,379

lurk

100+ Head-Fier
Joined
Jan 11, 2015
Messages
207
Reaction score
35
Joined
Jan 11, 2015
Posts
207
Likes
35
Mine does, but it's coax jack on the Mojo, the port is not loose (no play) when the 3.5mm is plugged in, but still same thing happens as in your video when i judge the cable
 
 
Quote:
  facing an issue here, not sure if it's covered under warranty
I use my mojo/dap stacks as portable, they are kept in my messenger bag while commuting
recently i notice the sound is breaking up whenever there is movement
 
i hv checked with several cables and able to pinpoint it to the mojo coax jack, when I twist the cable around while plugged in, the sounds breaks (power button light on the mojo flickers)
it does not happen on the X5 coax out jack. I hv tried switching both ends/3 cable types
 
mojo > fiio L17 > X5
being a portable, I kinda expect the L17 will be 'pushed' around a bit while in my bag
 
 
  With the included micro usb cable it's loose at the Mojo side and loses connection with my phone if the cable is nudged slightly up or down, only a gentle nudge is required to make it lose connection.  
 
I connected a couple of other micro usb cables which seem a bit better and require more of a nudge to break the connection but it still happens. 
 
Not ideal if strapping it to my phone.  Is anybody else experiencing this? Do I have a defective unit?
 
 
 
     Share This Post       
post-12280860
Post #9,881 of 40,379

betula

Headphoneus Supremus
Joined
Oct 27, 2012
Messages
3,711
Reaction score
3,031
Location
U.K.
Joined
Oct 27, 2012
Location
U.K.
Posts
3,711
Likes
3,031
  With the included micro usb cable it's loose at the Mojo side and loses connection with my phone if the cable is nudged slightly up or down, only a gentle nudge is required to make it lose connection.  
 
I connected a couple of other micro usb cables which seem a bit better and require more of a nudge to break the connection but it still happens. 
 
Not ideal if strapping it to my phone.  Is anybody else experiencing this? Do I have a defective unit?
 
 

My factory cable did the same, however I didn't experience any problem with other usb cables. So in my case the factory cable was defective.
 
     Share This Post       
post-12280864
Post #9,882 of 40,379

audi0nick128

500+ Head-Fier
Joined
Dec 30, 2015
Messages
620
Reaction score
240
Location
Northern Germany
Joined
Dec 30, 2015
Location
Northern Germany
Posts
620
Likes
240
Hey there,
I am planing to get rid of the smartphone as primary source, therefore I am going to build a Raspberry Pi 2 Streamer running Music Demon Player.
Has somebody tried this combination with mojo before?

Cheers
 
     Share This Post       
post-12281022
Post #9,883 of 40,379

SLCanhead

100+ Head-Fier
Joined
Apr 7, 2006
Messages
274
Reaction score
22
Joined
Apr 7, 2006
Posts
274
Likes
22
  Try charging overnight with the unit off. The charging circuit looks at the state of the battery before charging. If the battery has a very low voltage, it will trickle charge the battery until it gets to a safe voltage, and then full charge will commence. This trickle charge mode can take several hours, and it is done for safety reasons, and it will appear that the battery is not working as the trickle charge mode takes some time. When in this mode Mojo must be off.
 
When charging make sure the battery light is white and not flashing - if it flashes, pull out the charging cable, count to ten, re-attach the charging cable. If it continues to flash, it is most likely the charger is not giving 1A at 5V, so use a better charger.
 
Rob 
 
 
  Thanks much for the response Rob. I will give it one more shot.
 
I have it charging again. The battery light is white and not flashing. The unit is off (as it won't stay on anyhow) and I will let it go overnight. I am just concerned due to the fact I let it charge for about 12 hours last time. Hopefully, it was just in a trickle charge mode as you mention. 
 
If it's somehow stuck with the power on, please let me know what I can do to check. I just don't think so being that it won't power on without the cable in, as if the battery has zero charge (and I have not held the power button after plugging the charger, to power it on.)
 
I charged it overnight using a charger that is 1A 5V charger, per what I was informed. It was solid white light last night, checking multiple times before bed, but was blinking as of this morning when I woke up.
 
I am using another charger (3rd different one, 1A 5V rated per my understanding) and it's solid light again, and has been like that for the past hour. 
 
I also purchased another charger and cable, and will revert to that as a "final option" if this doesn't work. The store rep said it's solid quality. I will have tried 4 different chargers and 4 different cables including the newest one, at that point. All of the chargers used (except the one I just purchased) have charged other devices without issue. I understand that the Mojo has particular charging device/power requirements, so I am doing my best to adhere to them.
 
     Share This Post       
post-12281023
Post #9,884 of 40,379

Staxton

Head-Fier
Joined
Dec 6, 2014
Messages
99
Reaction score
149
Joined
Dec 6, 2014
Posts
99
Likes
149
Hey there,
I am planing to get rid of the smartphone as primary source, therefore I am going to build a Raspberry Pi 2 Streamer running Music Demon Player.
Has somebody tried this combination with mojo before?

Cheers
I've been using the Mojo with a Raspberry Pi 2 (using RuneAudio, which is based on the Music Player Daemon), the Banana Pro (using MPD and the Gnome Music Player Client), and a Cubietruck (with RuneAudio), and the Mojo sounded great with all of them. I been trying these low power boards because I can attach USB (on the Raspberry Pi) or SATA drives (on the Banana Pro and the Cubietruck) to them for more storage than I can get on a phone. 
 
Best,
Rod
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 1, Guests: 16)

Top