1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Chord Mojo DAC-amp ☆★►FAQ in 3rd post!◄★☆

Discussion in 'Portable Source Gear' started by Mython, Oct 14, 2015.
  1. costas23
     
    Yes, great pairing! ....as with every headphone I tried the Mojo with :wink: 
     
    Mojo drives everything just great, even my Senns HD800 as well as tiny IEMs.. it's an all-in-one-wonder really ... especially the HD800 or the 325e sound smooth and delicate but with lots of prat and power
     
    I think the incredible dynamic range of the Mojo is one of its greatest strengths.. by that I not only mean that it can drive nearly every headphone properly, but how it portraits the dynamic range of a song with a given headphone, i.e. the loud and low volume bits of a song. If you listen to classic or other not DR-compressed music with a good headphone you will immidiately notice, that the mojo can do something that other DACs and amps can't. The way the mojo sends sounds from near to far or brings sound from the deep back to front is amazing. The sound travels very naturally.
    I think this wide DR is responsible for the deep-3D-soundstage and "musical reality"
     
    headmanPL likes this.
  2. masterpfa
    Grrrrrr hate Android Upsampling, I'm sure there is a reason why they do this
     
    Great pairing for me
     
  3. warrior1975
    I think they do it because it gives the illusion that it sounds better... Us audiophile type music experts know better. :wink:
     
  4. masterpfa
    [​IMG]
     
  5. Mython Contributor
     
    Hey, speak for yourself!
     
    I'm no expert!  (well, not at audiophile stuff [​IMG])
     
  6. Mython Contributor
     
     
    Do you mean Samsung are preventing people from installing UAPP etc. to circumvent Androids native upsampling?
     
  7. sabloke
    Ly LG G4 died of bootloop last week, so it is now with LG to get it fixed. Had to live 4 hours without a phone and that almost killed me! Grabbed a Nexus 6P outright in a hurry, which I absolutely love, but there's one small issue with it: Type C port. None of my half dozen micro USB OTG cables and adapters work. I tried, of course, all of them, but the problem is they all need to plug into the phone and that's not possible. This new port is great, charging the phone in no time with a blasting 3.5A power adapter, but when it comes to plugging the Mojo it just a pain... Lucky my Onkyo DP-X1 does such a nice job! Any recommendations for Type C OTG cable?
     
    GreenBow likes this.
  8. captblaze
     
    like this? -----> http://www.amazon.com/Type-C-Cable-quality-Female-Black/dp/B00SHM4HS4
     
  9. sabloke
    I was hoping for a 10cm Type-C to micro USB OTG, but I suppose that will have to do.
     
  10. noobandroid
    i can install and use on my note 4
     
  11. Mython Contributor
     
    Sorry,  I meant on the S7 edge, as per  iKE1985's remark, to which I was responding
     
     
     
    Cheers, anyway
     
  12. Mython Contributor
     
     
    Nice, but that will require a 2nd cable (the one included in Mojos box).
     
    I think sabloke is probably seeking a single-cable solution
     
  13. music4mhell
    Hello Rob,
     
    If 2 micro usb otg cable have exact same RF noise, then can we assume that the SQ will be same for both OTG cables ?
     
  14. golfpro

    ​Actually it's ATT and one other company will not let you root some android devices, maybe others.  I tried to root my note 4 through ATT, went to the root page, and right there in black and white it says ATT and one other company won't let you root.  Definitely switching in a few months when the contract runs out.!
     
  15. Kermy
    Before I take my Mojo back to the dealer for them to check out, has anyone experienced an issue where the USB input suddenly stops working? It was working earlier, then had to unplug my iPhone to go to a meeting and by the time I came back and plugged in again, the phone would not detect the Mojo. The power light on the Mojo shows red. I went home and plugged it into my computer which was working fine with the Mojo the night before and same issue where it doesn't detect the Mojo.
     
    I've tried rebooting the iPhone and computer, turned on/off the Mojo, and changing cables. Any thoughts?
     

Share This Page