Buzzing sound form speaker...
Mar 8, 2007 at 11:30 PM Thread Starter Post #1 of 3

Dr.Love

100+ Head-Fier
Joined
Nov 7, 2005
Posts
374
Likes
12
I picked up two dynaudio bm5a monitors the other night, one of them was making a buzzing sound when turned on with no music playing the other was fine with just the standard hiss. So I exchanged the speaker making the buzzing sound for another speaker, and I just hooked it up tonight and still the same sound. I don't think it's a ground loop because I unplugged the other speaker and even swapped xlr cables between the two and still the same sound.

When I turn the decible switch in the back down to -10 on the one thats buzzing the sound goes away, also it declones quite a bit when I set the the bass bypass switch down to 80 or 60. I thought it would be improbable to get another speaker with the exact same problem so I have no idea what it may be other than another bad speaker.

Or is this common and the sound I'm hearing is fine and not a sign of a damaged speaker or connection? I'm kinda new to this stuff so all replies are welcome.
 
Mar 9, 2007 at 1:26 AM Post #2 of 3

lini

Thought the last line in Citizen Kane was nosebud.
Joined
Jun 22, 2001
Posts
6,119
Likes
28
Location
Munich, Bavaria
Is the buzz also present, when you don't have any signal cable connected? And if you exchange the left with the right speaker and vice versa, what happens?

Greetings from Munich!

Manfred / lini
 
Mar 9, 2007 at 1:34 AM Post #3 of 3

Dr.Love

100+ Head-Fier
Joined
Nov 7, 2005
Posts
374
Likes
12
Hi! It's the speaker, because I can't replicate the sound on the other in any configuration so instead of returning one yet again I've decided to return both and stick with my non-buzzing M-Audio BX-8a's/SBX sub.

Thanks for the reply!
 

Users who are viewing this thread

Top