1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Bose AE2 Headphones Hiss Sound issue.

Discussion in 'Headphones (full-size)' started by imawhale, Aug 20, 2012.
  1. Imawhale
    So I recently got a pair of these very comfortable Bose AE2's. When I plugged them in I immediately heard a hiss sound. So I muted my audio on Windows and the hissing consists. Even when I mute windows completely I still hear this electrical hissing sound.
     
     
    When I unplug it from my PC Tower the static go's away...obviously. This is my first time dealing with a pair of headphones of this caliber. I'm used to something such as 60$ headsets like the Razer Carcharias. I got these from Best Buy, now the problem is...do I want to take a 2hr trip to Best Buy, and get them exchanged, or is natural? I've reinstalled on on board sound drivers completely, no difference I've tried different audio jacks two on the front 1 in the back no real difference. 
     
    Any tips/personal experience with Bose AE2's producing a hiss sound when plugged into a PC? 
     
  2. obobskivich
    It isn't the headphones, it's the PC. Sounds like grounding issues and/or sensitivity/impedance mismatch. Get a soundcard or some other device to get off the onboard audio and you should be AOK. There are plenty of cheap options.
     
  3. Imawhale
    Quote:
    Yea, this appears correct. After reading this I tested it on a different PC. It appears to sound clear. Guess it's just my ****ty on board sound card, which is great. I hate going to Best-Buy to return/exchange things. I guess I'll simply be going to get an actual sound card. Should be fun thanks! 
     

Share This Page