1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

AVOID! Please, for your hearing, stay away from iBasso DX50

Discussion in 'Portable Source Gear' started by yggdrassilious, Sep 29, 2013.
First
 
Back
1 2 3 4 5 6
8 9 10 11 12
Next
 
Last
  1. spurxiii
    That's good. I don't think it's been reported anywhere else has it?
     
  2. H20Fidelity Contributor
     
    Not that I've seen so far. 
     
  3. DigitalFreak
    ....never mind
    Best hold my peace
     
  4. goody
    guys has the bugs been sorted yet?....what headphone amp do you guys recommend for my ipod classic?.jds labs c5
     
  5. H20Fidelity Contributor
    I remain fairly confident the volume bug has been addressed in firmware v1.2, yes. It's not occurred to my player since or have I read any further reports.
     
  6. spurxiii
    I've had no issues with volume since 1.20 also
     
  7. jamato8 Contributor
    No issues with the volume on my DX50. Working and playing just fine. 
     
  8. Jpfe8851
    I think we can reasonably assume this is fixed. I had one instance of up and one down on 1.1.5 or 1.1.6 and now with two weeks regular use on 1.2.0, nothing at all and as H20 confirms, the whole volume response is much improved...

    I would also confirm that the volume never jumped instantly to max. I had plenty of time to pull the cable from the headphone jack the one time it happened to me. But it's all now moot IMHO.

    Time to put this to bed....:)
     
  9. jamato8 Contributor
    It never happened on mine, which I am glad of. It does seem to be done and over with now. My DX50 plays all types of formats and up to and including 24/192 so I am happy. 
     
  10. 24Bit
     
    Did anyone really worry? :)
     
  11. Carlsan
    Reviving this thread. I'm having these issues with firmware 1.2.8
    Will play fine for hours, then volume goes to the max, without any handling of the DX50, I barely have time to yank the earphones out of my ears.
     
    Not fun. [​IMG]
     
  12. 808Ronin
    Never had this problem but the thought of it did concern me. I went back to using LO thru my c5 amp, problem solved.
     
  13. H20Fidelity Contributor

    Email iBasso immediately and inform them, I went through it last year and it wasn't much fun, though we thought it was patched in an early firmware. It needs to be addressed from their side.
     
  14. DigitalFreak
    Guys, there's a Rickbox port that so far is getting good reviews for the DX50. If anyone on here is desperate enough maybe look into Rockbox. I'm personally going to wait for a more stable version before I do anything
     
  15. headwhacker
    It's worth trying Rockbox now with DX50. You can toggle back and forth between Rockbox and the original FW (Mango). At least on the latest Rockbox update, UI (touchscreen + buttons) is much more functional than mango. I have not encountered any playback issues yet (though only have ALAC files and mix of different bit/sampling rates), so it's looking very solid right now.
     
    http://www.head-fi.org/t/709855/ibasso-dx50-rockbox-finally-here-latest-update-2014-03-14b2/45
     
First
 
Back
1 2 3 4 5 6
8 9 10 11 12
Next
 
Last

Share This Page