Audeze Penrose X and Penrose
Dec 10, 2020 at 4:06 PM Post #3,077 of 5,899

Dksk8

New Head-Fier
Joined
Oct 14, 2020
Posts
16
Likes
5
Location
Illinois
Can someone tell me how to update this? I extracted the file but there's still no firmware showing in the app. What am I doing wrong? Im on Windows
Nvm figured it out. Thank you Audeze! That woosh sound is all gone! I was worried I got a bad pair. This is now my favorite headset. It truly sounds super clear. My first planar headset and wont be my last.
 
Dec 10, 2020 at 4:23 PM Post #3,078 of 5,899

candurin

New Head-Fier
Joined
Jan 7, 2013
Posts
43
Likes
21
The sound is amazing. I just wish they had more padding up top for us bald folks.

@Audeze it’s a shame to have to spend extra money to make the headband more comfortable (I’m bald). If you want to send something comfy to me for Christmas, I won’t say no :)
 
Dec 10, 2020 at 4:47 PM Post #3,080 of 5,899

Fox11

New Head-Fier
Joined
Apr 24, 2017
Posts
14
Likes
7
I've updated to the latest software/firmware (as others have said, mic does seem better).

The EQ feature seems extremely broken, though...? Half the sliders just made ALL the sound get quieter or louder, and the sliders appear to be inverted...? Has anyone else experienced this?
 
Dec 10, 2020 at 5:03 PM Post #3,081 of 5,899

Arkard1

Head-Fier
Joined
Nov 23, 2020
Posts
92
Likes
37
Location
Usa
I've updated to the latest software/firmware (as others have said, mic does seem better).

The EQ feature seems extremely broken, though...? Half the sliders just made ALL the sound get quieter or louder, and the sliders appear to be inverted...? Has anyone else experienced this?
Audeze had stated that this is a feature of you turn your gain to high the volume goes down to compensate for distortion
 
Dec 10, 2020 at 6:11 PM Post #3,082 of 5,899

Cafofo

New Head-Fier
Joined
Jan 14, 2010
Posts
32
Likes
17
Guys,

After upgrading the firmware I think some things got better specially the mic.

But right after upgrading I could use windows settings to setup the speakers Balance and I could make it work well both sides.
But after restarting windows I cannot do it anymore and the settings were not save.
Any thoughts in how to make it happen again?
edit: using wireless
 
Last edited:
Dec 10, 2020 at 6:16 PM Post #3,083 of 5,899

higgalls

New Head-Fier
Joined
Dec 8, 2020
Posts
20
Likes
3
Location
Sydney
I’m really torn. I want to buy my first gaming headset, but the reports on here are mixed with the penrose. And the Sydney dealer doesn’t have a good returns policy if they are too uncomfortable (they charge a 20% restocking fee), and they don’t have any in store to check out before buying.
 
Dec 10, 2020 at 6:47 PM Post #3,084 of 5,899

drsnowball

New Head-Fier
Joined
Nov 25, 2020
Posts
38
Likes
43
Location
USA
From one “first gaming headset” buyer to another, if you’re looking at a 20% fee minimum... I wouldn’t buy these. I’ve decided to return them now that I’ve listened to them with the new firmware. I find them extremely uncomfortable and can’t imagine wearing them for longer than two hours at a stretch, and that’s with powering through a ton of discomfort.
 
Dec 10, 2020 at 7:14 PM Post #3,085 of 5,899
Joined
May 28, 2009
Posts
1,072
Likes
2,108
Location
Costa Mesa, CA
I've updated to the latest software/firmware (as others have said, mic does seem better).

The EQ feature seems extremely broken, though...? Half the sliders just made ALL the sound get quieter or louder, and the sliders appear to be inverted...? Has anyone else experienced this?
Since there are multiple audio sources and multiple levels of amplification, automatic gain control kicks in to make sure we dont clip. Adjust the EQ, then use the volume control on the headset to finalize the loudness.
 
Audeze Stay updated on Audeze at their sponsor profile on Head-Fi.
 
https://www.facebook.com/AudezeLLC https://twitter.com/audeze https://www.audeze.com/
Dec 10, 2020 at 8:14 PM Post #3,086 of 5,899

scratchmassive

Head-Fier
Joined
Sep 30, 2020
Posts
65
Likes
55
Location
Australia
@Audeze I've installed the latest firmware. Wooshing sound is gone. But there is still audible noise when sidetone is enabled, which disappears when flipping the mic mute switch. Was this intended to be resolved in the update? If not, is it an issue that can or will be fixed?
 
Dec 10, 2020 at 8:16 PM Post #3,087 of 5,899

Mazaloud

New Head-Fier
Joined
Nov 17, 2020
Posts
5
Likes
6
Location
East Coast US
Is anyone else experiencing a periodic high pitched noise in the left side of the headphones? Every few minutes it shows up. It's not so loud as to distract me if I was listening to loud music but it is noticeable while playing quieter games or watching videos. It oscillates in volume and pitch for a bit and then goes away. I've tried all my USB ports as well as an external hub, and have tried different spots in my house. No luck.
 
Dec 10, 2020 at 8:18 PM Post #3,088 of 5,899

Gunn3y

Head-Fier
Joined
Oct 13, 2020
Posts
89
Likes
58
Location
Sydney, AU
I remember having the same 'hotspot' withe the Mobius I had. In the end I think I used a couple of Dekoni Nuggets (one each side of the pad) to spread the pressure a little which certainly helped.

So from the 30 minutes or so i tested them yesterday, i can tell there is going to be a comfort issues on the top of my head on any proper session, particularly once the clamp has been loosened a bit. Coming from Audio Technica AD700s i guess i had underestimated just how much less comfortable other headsets could be.

Would be keen to hear from anyone with access to something like these Dekoni Nuggets as to whether they are a viable option for the Penrose, before i spend another $45AUD with the supplier i'll apparently be paying a 20% restocking fee to if i return the Penrose due to comfort issues.
 
Dec 10, 2020 at 8:46 PM Post #3,090 of 5,899

Cazorp

New Head-Fier
Joined
Oct 22, 2020
Posts
38
Likes
40
Location
USA
Is anyone else experiencing a periodic high pitched noise in the left side of the headphones? Every few minutes it shows up. It's not so loud as to distract me if I was listening to loud music but it is noticeable while playing quieter games or watching videos. It oscillates in volume and pitch for a bit and then goes away. I've tried all my USB ports as well as an external hub, and have tried different spots in my house. No luck.

Does it sound like a high pitched, vintage recording of wind? Like this, but a single source that's less chaotic

This is the "wind sound" that was worked on in the firmware update, but I still have it. It's in the left can only.
 

Users who are viewing this thread

Top