1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

ASUS Essence One cannot enter firmware update mode - repair manual

Discussion in 'Dedicated Source Components' started by daniser, Mar 11, 2018.
  1. daniser
    Hello all,
    Some people trying to convert their MKI units to MKII with ASUS DSD upgrade kit or via reflashing their DIP8 EEPROM chips with appropriate firmware face the issue of inability to update their MCU chip. Updating MCU firmware to version 0.64 is essential to complete transformation to MKII otherwise you will not hear any output when playing DSD content. In order to update said FW, you need your unit to enter service mode. Usually it is done via pressing UPSAMPLING+MUTE buttons when powering on your unit till you found all 3 input LEDs (COA/TOS/USB) flashing red. Unfortunately, some units unable to enter service mode because of wrongly factory programmed chip configuration bits.

    [​IMG]
    The culprit. Photo stolen from raoultrifan post dating some centuries ago.

    Here comes the solution.
    Don't forget: do it on your own risk. You can easily fry your unit, yourself or your cat!
    P.S. Not at all really, but still... Be careful.


    1. First of all, you need to buy some hardware. Look here or here. Cheapest option will be enough.
    These are Nuvoton's debug adapters which we'll use to fix config bits on our ARM Cortex-M0 series M054ZAN chip (M051 series datasheet).

    [​IMG]

    2. Then, you need to open enclosure of you Essence One and find row of 5 pins marked J4 on Essence PCB. This is Nuvoton's SWD (serial wire debug) port. Connect your Nu-Link or Nu-Link PRO adapter to these pins directly or using supplied extension cable. Pin marked white is VCC pin. Essence One unit must be de-energized during procedure.

    [​IMG]
    [​IMG]

    3. Download and install Nutovon ICP Programming Tool from their software download page. Connect your adapter to free USB port of your PC. Wait until all the drivers are installed, then start the software. You may be prompted to update firmware on your Nu-Link adapter if it's out-of-date. Confirm and wait till it's done flashing it.

    [​IMG]

    In the next window, select M051 Series as target chip and click continue.

    [​IMG]

    Now we are in the main window. Software will try co connect to the target chip via Nu-Link adapter. If it succeeds, you will see green "Chip connected" message and chip information.
    In order to spare time, we can update config bits and firmware to version 0.64 simultaneously. (Otherwise you'll have to update FW later via ASUS FW update utility which comes complete with the firmware file itself).

    4. Before doing next step, we can save current chip contents in case of something will go out of hand. Alternately switch tabs in the "On-board flash" section and click "Save As" button each time in order to save LDROM, APROM and Data Flash contents to corresponding files. For those who missed that step and got into a mess later: don't rush to begin running around and screaming - I have did that step myself and saved contents of chip's EEPROM for you (see the attachment)! Hopefully we won't need that but still - better to reinsure.

    FYI: The APROM contents was identical bit-to-bit to my current MCU FW 1.27 which I especially downloaded from ASUS website and compared to saved one in hex editor:

    [​IMG]

    The one exception was the length of the files: the APROM one was zero-filled to APROM section boundary, the downloaded one wasn't.

    5. Now it's time to do the main thing. Choose programming options, set correct config bits and select 0.64 FW file as shown in the screenshot below:

    [​IMG]
    config.ini file from ASUS FW update package was used as reference for chip configuration options.

    Press start and enjoy the moment of suspension.
    When all done, close the program and disconnect everything, assemble DAC, power it on, etc... You know what to do!

    [​IMG]
    Result.

    If you'll try to connect your Essence via SWD port again, don't panic when you'll see this message:

    [​IMG]
    Don't press "Da" if you're not confident.

    It is because of Security Lock bit we set in configuration bits - just press "Cancel" to disconnect or "Yes" if you plan to reflash your device again.

    6. If you believe in magic or have OCD you can now reflash your unit with standard ASUS FW utility. Press UPSAMPLING+MUTE, then power on the unit still holding these buttons. When red lights will stop flashing, start the utility, press "Connect" and "Update", sit back and relax.

    [​IMG]
    [​IMG]

    I hope these instructions will help somebody to overcome the issue and enjoy DSD playback on Essence One.
    Good luck!
     
    Last edited: Mar 12, 2018
    raoultrifan likes this.
  2. raoultrifan
    Very comprehensive, love your work!
     
  3. raoultrifan
    BTW, to fully decode DSD files you still need the original DIP8 chip. This contains the DSD decoding algorithm, so without the DSD DIP8 EEPROM when playing DSD files there will be a "hiss" on the playback.

    P.S.: After doing the above operations will you be able to press the 3-buttons to put the Essence One into firmware upgrade mode correctly every time, right (like shown on step 6)? Or the new firmware upgrades should be done in the same way (with the NU-LINK-PRO adapter)?
     
  4. daniser
    Yes, you'll be able to load device into FW upgrade mode any time you wish. The problem was in a single configuration bit which told the device to load directly to main firmware (APROM) omitting bootloader code (LDROM). On boot LDROM code checks if 2-button combination is pressed then deciding to enter FW upgrade mode or proceed to load APROM code.
     
  5. O c t o p u s
  6. daniser
    I think it will work, but I can't guarantee it 100% as it is a clone and not the original tool by Nuvoton.
    So better ask the seller about possible compatibility issues (like original software and firmware compatibility).
    P.S. Please reply your results in this thread.
     
    Last edited: Dec 17, 2018
  7. O c t o p u s
    Man... You are an ABSOLUTE STAR!

    This worked like a charm...

    Many many thanks for your AWESOME guide... Simple and easy to follow.

    Again, thanks a A LOT
     
    daniser likes this.
  8. daniser
    I'm glad my efforts weren't in vain. I only regret I found this out a little bit too late.
    So you've used this tool from AliExpress, was it needed special software or worked just fine with official Nuvoton software/firmware?
     
  9. O c t o p u s
    It worked like a charm. Without any special software, it detected the "tool" and upgraded the firmware just as you said it will... running the official Nuvoton Programming software.

    Now, I just don't know, what else could I use it for... :):):)
     
  10. daniser
    Well, I kept mine for possible future DIY projects (who am I kidding, huh :beyersmile:?..).
    You can sell it to whoever interested in it. Possible some other ASUS victim on this forum))
     

Share This Page