1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Android phones and USB DACs

Discussion in 'Portable Source Gear' started by nztechfreak, Feb 9, 2012.
First
 
Back
496 497 498 499 500 501 502 503 504 505
507 508 509 510 511 512 513 514 515 516
Next
 
Last
  1. JuleZ3C
    Hello guys,
     
    I just got an Asus Zenpad running lolipop, I've tried it on three different DACs (Ifi micro IDSD, Schitt Bimby, Teac AI-301DA) using two different OTG cables, symptoms are the same : there's some sound but mostly an annoying continuous, cyclic 'tick tick tick' above it that I can't get rid of...
     
    Anyone experienced this with other devices?
     
    Thanks
     
  2. greenpsycho
    OK I must be super lucky. I had a nexus 6 and now nexus 6p, plugged them into my modi and idac2 and both worked right off the bat with Google music and cloud player. Even seemingly does full 24/192 on my 6p (at least according to my idac2 led)
     
  3. m-i-c-k-e-y
    @JuleZ3C

    If I remembered it correctly (it happened 2 yrs ago).

    2 things:
    a. It went away when I hook up my DAC to an external power using a Y cable.
    b. When I upgraded my Android OS to 4.4.2
     
  4. JuleZ3C
    Thanks m-i-c-k-e-y
     
    I'm on Android 5.0.2, and two of the DACs I tried are externally powered...
     
  5. m-i-c-k-e-y
    Player? I have my best experiences on UAPP next Hiby
     
  6. shuto77
    Which micro USB to micro usb cables do you guys recommend?

    My Oppo HA-2 sometimes works flawlessly with my HTC One M8,and other times won't work even though the phone is detecting the DAC and going into USB Host Mode.

    I'm running Android 5.0.2.

    I'm hoping a new cable may solve the issue.

    Thanks!
     
  7. Piggy
    I made the cable myself. It is just a four wires straight through cable, with pin4 and pin5 shorted at both ends. If you have a DMM, you may check the cable first. But I don't think it's the problem of the cable.
     
  8. Buckster
    thanks to someone on xda forums manged to get my E17 working with my Note 3
     
    before I had very distorted - slow sound - very wrong
     
    http://forum.xda-developers.com/showpost.php?p=63562588&postcount=26
     
    thanks to above post/poster
     
    after trying above my USB DAC works with Spotify :)
     
    tried same "trick" with my Tab S - and no go :frowning2: but works fine on my Note 3
     
  9. shuto77

    Interesting. Why do you think it works sometimes, but not others via Android? I've swapped out cables, and never have an issue using it with my Windows 7 pc.
     
  10. Peridot
    I have a Samsung Galaxy S3 (i9300) as a dedicated music player.
     
    It was on an Android 4.3 based OmegaRom (pretty similar to stock), and was working fine for USB audio out to my FiiO E18 either from Android or via Onkyo/USB APP.
     
    I've started using Tidal and the Android App wasn't working well with 4.3 so I upgraded to Cyanogenmod 11 ROM. I can no longer get Android audio out over USB and can only use Onkyo or USB APP.
     
    Is anyone aware of a ROM that will restore USB audio out from the dedicated Spotify and Tidal apps, or a way of getting this to work on the S3 under CM11?
     
    I can use Tidal via USB APP, but want to have access to offline content for which I need the dedicated app.
     
    TIA [​IMG]
     
  11. Piggy
    To make it work, the cell phone and the HA 2 must be physically connect(HW) and communicate (SW).
     
    If your cable is a two way OTG cable and is not broken, the cell phone and the HA 2  is physically connected. Nothing special about it really.
     
    If it can't communicate flawlessly, it is the SW, either the firmware of the cell phone or the HA 2 or the music app itself or some SW conflicts between apps.
     
    Temporary uninstall all the music app, just use the music player of the M8 and see if it works all the time. If it doesn't, it is the M8 firmware issue. If it does, reinstall back Tidal and try it.
     
    Android is completely different, don't expect it work like window. Even my LG G3 works flawlessly with the HA 2, if you are planning to buy the V10, you still have to search the web and see if it works.
     
    The firmware version of my HA2 is 6.76.
     
  12. 1235
     
    So my Type-C to USB Standard-A adapter from the Play Store has arrived and I've had some time to test.
     
    6P > Type-C to USB Standard-A adapter > regular old type A to Micro type B > ODAC > Amp > monitors. 
     
    Still can't get the ODAC to work with the 6P.
     
    It will briefly indicate the ODAC has connected before immediately stating it has subsequently disconnected. The phone refuses to reboot, or boot with the DAC attached. Offers default app USB use when I unplug the ODAC, but will not recognise it after plugging it back in. I've tried all the USB connection options, no luck with any of them. I'm picking this is a power supply issue and not due to the aforementioned cables.
     
    Sadly, I'm giving up with the ODAC for Android use.
     
    Thanks again to those who offered assistance.
     
  13. DanBa
    @1235 it should work if every software/hardware USB audio-required component is functional.
     
     
    Android USB audio
    FAQ
    http://www.head-fi.org/t/595071/android-phones-and-usb-dacs
     
    I have an Android device, a USB DAC and a USB Type-C cable which are reportedly compatible, but I have not been able to make it work. Is there a trick to make it work?

     
    Nexus 6P is reportedly compatible with a standard USB DAC (i.e. the USB host driver of the Nexus 6P can work with the ODAC).
    http://www.head-fi.org/t/595071/android-phones-and-usb-dacs
     
    The Google USB Type-C to USB Standard-A Adapter is reportedly working with a standard USB DAC like the ODAC and a dual-role Android device like the Nexus 6P.
    http://www.head-fi.org/t/595071/android-phones-and-usb-dacs
     
    I have an ODAC.
    My ODAC is compatible with the following different third-party USB audio soft drivers: UAPP, HibyMusic, Onkyo HF Player, Neutron (i.e. UAPP, HibyMusic, Onkyo HF Player or Neutron running on a Nexus 6P, an Android device with a fully functional USB host driver, can work with an ODAC).
     
    And I just found that the ODAC is no more compatible with the native USB audio of the current version of Android running on my Samsung Galaxy Note3. A few weeks ago, at the upgrade to Android 5.0, it worked!
    It is not a problem for me, because I listen to music using the third-party USB audio music player UAPP, the best sound music playback software to my ears.
     
    1st question: What (native USB audio or third-party USB audio) music player did you use?
    If the native USB audio does not work then you need to use one of the third-party USB audio music players which include their own USB audio function / soft driver compatible with the ODAC.
     
     
    Some component of the setup is malfunctioning.
     
    Each component should be separately tested: Go to next test only if the ongoing test is successful. A reset of the Android device is recommended before testing.
     
     

    2nd question: Did you reset your Android device?
     
     
    . Test the USB DAC with a PC or a Mac:
    PC >> regular USB cable provided by the USB DAC maker >> USB DAC >> amp >> headphones
     

    I suppose you have tested your ODAC with a PC / Mac.
     
    . Test the Android device and a USB Type-C adapter with a simpler USB peripheral like a USB mouse or a USB keyboard:
     
     
    3rd question: Did you test your Android device and your USB Type-C adapter with a simpler USB peripheral?
     
     
    Android device >> USB Type-C plug to USB Standard-A receptacle adapter >> USB mouse


    . Test the setup using the USB Type-C adapter:
    Android device >> USB Type-C plug to USB Standard-A receptacle adapter + regular USB cable >> USB DAC >> amp >> headphones
     
     If the tests are successful, apparently the USB Type-C cable is not functional (i.e. CC pin of the USB Type-C plug not connected to GND through a resistor Rd (5.1 kΩ)), then fix the USB Type-C cable or buy a new one.
    Android device >> USB Type-C plug to USB Micro-B / Mini-B / Standard-B plug cable >> USB DAC >> amp >> headphones

     
     
    "Important: connect your device BEFORE starting the app, otherwise it will not get detected! When you connected your device before starting the app and it gave you a 'failed to initialize or open the USB device' message or similar."
    http://www.extreamsd.com/index.php/2015-07-22-12-01-14/usb-audio-driver
     
  14. 1235
    Hi DanBa, thanks again.
     
    For the benefit of the forum I will address your further questions. 
     
    1. I've tried all of the mentioned TP apps. This is in addition to native app.
    2. I'm running 6.0.1, stock, rooted with a handful of Xposed mods. For the record, yes I have tested at completely stock on 6.0 and 6.0.1.
    3. The ODAC works fine on my PC.
    4. Simple peripherals work fine on the 6P with the Type A to Type C adapter.
    5. I've tested with all combinations of possible orders to plug in cables and start apps.
     
    The ODAC refuses to work with my 6P. I'm sure it would work with a powered USB hub, but at that point portability is somewhat defeated. I see someone else reported success with the C5D, but I think this has an internal battery.
     
    In summary, I've tested this to death. The ODAC does not have my recommendation as an appropriate device to use with either a Galaxy S6 or a Nexus 6P. The ODAC will find good use elsewhere and has so far escaped from being run over (so far). YMMV.
     
  15. imeem
    I got my fiio e17 working with my nexus 4 after installing CM 11, installing this kernel , and using a usb otg y cable. Tested using Hibymusic.
     
First
 
Back
496 497 498 499 500 501 502 503 504 505
507 508 509 510 511 512 513 514 515 516
Next
 
Last

Share This Page