Algae growing?
post-15806470
Thread Starter
Post #1 of 4

HamsterKing

100+ Head-Fier
Joined
Nov 26, 2014
Messages
195
Reaction score
52
Joined
Nov 26, 2014
Posts
195
Likes
52
Hey guys,

Bought a luminox cable for less than 1 year and there's some green thing appearing is it algae or?
IMAG5354.jpg
 
     Share This Post       
post-15806476
Post #2 of 4

MarkParity

Head-Fier
Joined
Mar 16, 2020
Messages
55
Reaction score
34
Location
UK
Joined
Mar 16, 2020
Location
UK
Posts
55
Likes
34
Its oxidisation of the copper where air and water (sweat) get into the cable. It won't affect the sound but it looks "not good". I've also found the the cable gets less supple as the green/black spreads.
 
     Share This Post       
  • Like
Reactions: HamsterKing
post-15806627
Post #3 of 4

HamsterKing

100+ Head-Fier
Joined
Nov 26, 2014
Messages
195
Reaction score
52
Joined
Nov 26, 2014
Posts
195
Likes
52
Its oxidisation of the copper where air and water (sweat) get into the cable. It won't affect the sound but it looks "not good". I've also found the the cable gets less supple as the green/black spreads.
Thanks for the info, didn't really use this cable much and it suddenly appeared
 
     Share This Post       
post-15823510
Post #4 of 4

normie610

500+ Head-Fier
Joined
Nov 25, 2015
Messages
802
Reaction score
731
Location
Jakarta, Indonesia
Joined
Nov 25, 2015
Location
Jakarta, Indonesia
Posts
802
Likes
731
Its oxidisation of the copper where air and water (sweat) get into the cable.
True, and it’s called patina, the same as the one that’s covering the statue of liberty :relaxed:
 
     Share This Post       
  • Like
Reactions: MarkParity

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top