or Connect
Head-Fi.org › lwrs10's profile

lwrs10

Forum Post Count:

217

Join Date:

2/23/07

Last Online:

on 12/29/14

It looks like lwrs10 hasn't added anything to their community profile yet.

lwrs10's Recent Activity

settings
(Uncheck the summary view to see ALL the gory details!) (Check the summary view to simplify the activity feed.)
lwrs10
updated their location 3/19/14 at 1:46pm
    Building a portable iPod DAC.
    lwrs10 posted in this thread in DIY (Do-It-Yourself) Discussions 2/26/13 at 7:19pm | 5 replies | 1122 views
    Emotiva XDA-2
    lwrs10 posted in this thread in Dedicated Source Components 2/26/13 at 6:02pm | 38 replies | 19007 views
    An Amazing $3 Headphone Stand
    lwrs10 posted in this thread in Cables, Power, Tweaks, Speakers,... 4/28/12 at 9:06pm | 14 replies | 2061 views
    Found some Ford headphones today.....yes Ford....
    lwrs10 posted in this thread in Portable Headphones, Earphones and In-Ear... 2/24/12 at 6:18pm | 1 replies | 441 views
    Tried out an Aune X1 DAC/Headphone amp
    lwrs10 posted in this thread in Dedicated Source Components 2/9/12 at 5:32am | 2 replies | 2960 views
    Calling All "Vintage" Integrated/Receiver Owners
    lwrs10 posted in this thread in Headphone Amps (full-size) 8/25/11 at 12:32pm | 16417 replies | 1375530 views

     

    lwrs10’s Photos

    Avatars
    2 photos
    73 views
    Latest upload: Jan 4, 2014
    Default
    9 photos
    520 views
    Latest upload: Apr 28, 2012

    lwrs10’s Embedded Photos

    lwrs10's photos in Aune T1 USB DAC+Tube Amp  Discussion Thread
    17 photos
    1,052 views
    Latest upload: Feb 11, 2014

    lwrs10's Lists

    0 Lists
    No lists.

    Head-Fi.org › lwrs10's profile