Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Meier Audio Porta Corda MkII Followup!
New Posts  All Forums:Forum Nav:

Meier Audio Porta Corda MkII Followup! - Page 14

post #196 of 242
sometimes mail comes 'early,' sometimes 'late,' but it almost always comes within the specified time. If it makes it any easier, I'm in Arkansas and havent' received mine.

Had a slip in my PO box and got excited, then was surprised to see a box from my friend.

it'll come
post #197 of 242

Got mine in SF, CA!

Mine came in today, and so far it's awesome! I switched it to class a and had a look around before I turned it on. Massive Attack sounds great! Nice subtle crossfeed and no loss of highs that I can perceive. Very smooth overall and I'm glad I went to this one from my last one!

Thanks Jude and Jan, you made another person happy!
post #198 of 242
It's Monday in southern California and I don't have it . (Mail already came for today).
post #199 of 242
I got mine in NJ on Friday. I'm loving it. But does someone know what are the settings on the toggle switch, its not in the owner's page, oh, manual.
It seems like a great product that is getting better with more burn in. My first battery is nearly dead (only playing in class A).

Thank you very much to Jan and Jude, I appreciate all your work.
post #200 of 242
Quote:
But does someone know what are the settings on the toggle switch, its not in the owner's page, oh, manual.
With the switch pointing to the 2 adjacent yet separate 'blobs', you are in stereo (no crossfeed) mode. Flip it to the 2 blobs that are partially connected, and you switch to 'Low Crossfeed' operation.
post #201 of 242
the settings are described under "optimization of current consumption" on the 3rd page.

the amp comes with white switches 1 & 2 open (up position) by default for class ab. i push mine down (closed) for class a & battery life has never been an issue.

switch 2 controls the LED. operational by default (closed) in the down position

switch 4 is non-functional.
post #202 of 242
Well, hasn't arrived in SoFla yet, hoping for it tomorrow!
post #203 of 242
I was able to pick mine up today from the office mail here in Los Angeles, California.

I look forward to playing around with it!

Thanks, Jan and Jude!


Hey, hmaxim - get yours yet?
post #204 of 242

Corda RX and Thanks

I received mine today in Boston. So far it sounds great driving my Grado SR-125 headphones. Should make a nice portable rig: Archos 420-Porta Corda-SR-125

Thanks to Jan and Jude, especially Jude for going far beyond the call of duty in organizing the group buy for Head-Fi members, for putting up with dozens of PM and emails from neurotic audiophiles (I’m at the top of the list) all asking when, when and when, and finally for Administering Head-Fi for no gain and little glory. I for one am sure that he is ultimately bound for canonization.

But that will have to wait. For now: Why isn’t the search function working? Just kidding.

Thanks Jude
post #205 of 242

Many thanks!

Again, many thanks to Jan and Jude! I got it from the post office today and I hook it with my 24V power supply. Put it to class A mode. It sounds great even before burn-in. It definitely helps my Grado 125 and Audio Technica A9000. I'm doing burn-it right now and hopefully it will sound better in few more days.

Thanks again!

desertracer in Arizona
post #206 of 242

Power issues...

I looked up the power supplies mentioned in this string and both Mouser and Allied both seem to be out of the linear one. Does anyone know where to get one now?


Thanks.
post #207 of 242
I recieved my amp yesterday! Thanks so much for putting this together guys!

sound quality is definitely better. I was playing with it last night on my A900's and could tell the difference somewhat, but this morning I plugged it into my KSC-35's (my usual portable phones) and immediately noticed a difference on the Orbital song I was listening to. I actually plugged in to the ipod directly because I couldn't believe how much better the chimes that were playing at the moment sounded. Definitely using class A mode. And this is all before it's burned in at all...not even an hour on it so far.

I like the crossfeed too. It's not a dramatic difference but definitely shifts the soundstage forward juuuust a bit to make it sound more natural.

I'll be watching for power suppply info too...I think I may get one to use at work to save the battery.

Now if ONLY my EW-9's would get here!!!
post #208 of 242
Ya know, I have to admit that when I was listening yesterday, I had it on pass through (no crossfeed) for the first part and I thought that was the crossfeed. After I figured out (from a post here) I'm not sure what to make of it. It almost sounds like I'm switching to mono and removing some bass.

I just sent back a Total Airhead because to me it took away highs in crossfeed mode. Other than that, I really liked the crossfeed on the TA. It spread things out, with out moving everything forward, yet it combined both channels and made it sound like I was in a room listening (more than three channels, no more bass boom). With the MKII, well, I'm not sure what to make of it yet. I really like that the highs are perfect, I'm just trying to adjust to the forward position. It does take away bass boom and combines the channels as well, just seems to push eveything back together again, it's weird. Anyone else notice this?

I'm using an iPod > HD650s btw...
post #209 of 242


whaaaaat?!? Picked it up this morning, and this lil' baby (and how!) is GREAT! Thanks so much, Jude and Jan. I've had a charged Plainview stashed in my kit bag just waiting for this!

I'm going manic switching back and forth from iPod to home source to PCDP, Porta Pros and MS-1s ... it's not really doing anything for me with HD25s, but with the other two, everything sounds better overall. My bass-check song, Stetsasonic's "The Odad," sounds tight and controlled, and the steel drums and kettle are crisp with both the PPs and MS1s; The Clash's "Lost in the Supermarket" just sounds sick, esp. the cymbals.

Definitely one of the hottest deals of 2004. Thanks again for making this happen!
post #210 of 242
Interesting stet, cos I find my new PC MKII makes a big diff with my HD-25s using my iPod and sik din.

- walkman666
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Something has gone wrong!

Please try again!

Something has gone wrong! Please refresh the page or try again later.

Tech support has been notified of the problem.

Error: 503 Service Unavailable

Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Meier Audio Porta Corda MkII Followup!