or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Rockbox for iBasso DX90 dual boot with Mango (Stock Firmware)
New Posts  All Forums:Forum Nav:

Rockbox for iBasso DX90 dual boot with Mango (Stock Firmware) - Page 12

post #166 of 1288
Thread Starter 
Quote:
Originally Posted by all999 View Post

Still can hear some cracklin, just qieter. I'm not sure about continous play, but there is some crackling for couple seconds after manualy switched tracks.


 



At this point, you have to closely discriminate the actual noise produced by switching tracks and the background noise in the tracks itself. I got a couple of gotchas myself but it turns out it's the noise coming from the track.

At worst, I only get a quick and soft click when switching tracks at the beginning. But not the noise that last a second or longer like what I can easily hear before. I still have not heard the noise while listening to a long playlist or album.

When I test switching tracks in this case I press the prev or fwd button once or twice . In this scenario I have not encounter any noise yet and imo is the best representation of a normal usage.

Also, if you are going to press the prev or fwd button in a very quick succession you are repeatedly forcing rockbox to dump and fill the buffer which increases the chance of hearing a noise. Still not as loud nor last as long as can be heared before.

If you are using a c/iem, a slight movement of your jaw can produce a similar effect or noise so you should be aware of it as well.
Edited by headwhacker - 7/28/14 at 6:15pm
post #167 of 1288

This is my first time using RockBox, and I have an extreme noob question:

 

I go to play a song in Rockbox, and it LOOKS like it's playing--the song counter is advancing, etc. However, I'm getting no sound whatsoever.  I'm not doing anything overtly silly, such as plugging the IEMs into the wrong output, and it works fine in Mango. Can you think of any reason why I wouldn't be getting any audio at all?

 

Thanks!

 

EDIT: I was able to get audio by doing a reset settings command. There is quite a learning curve with the Rockbox UI, but I'm finding it interesting to try out and compare to Mango.


Edited by bigsix - 7/28/14 at 11:26pm
post #168 of 1288
I noticed that the wallpaper I have set for mango disappears after rebooting the player
post #169 of 1288
Quote:
Originally Posted by burningv View Post
 

Is there anyway to revert back to the Mango firmware without the dual boot option? I'm not really as big of a fan of Rockbox as I was on the iPod Classic. Navigating Rockbox on the DX90 seems rather cumbersome to me and I would rather prefer to use Mango's intuitive UI. Sorry, I guess Rockbox isn't for me. 

 

For me RB is really useful if you have an IEM who have a bad pairing with the DX90, eg too bright and you need to add bass, in this case RB is really better than Mango despite the interface that requires time adaptation. Congratulations again for this port and to have included the latest bit perfect Mango firmware by Lurker0 :smile: 


Edited by Migou67 - 7/28/14 at 10:49pm
post #170 of 1288
Quote:
Originally Posted by Migou67 View Post
 

 

For me RB is really useful if you have an IEM who have a bad pairing with the DX90, eg too bright and you need to add bass, in this case RB is really better than Mango despite the interface that requires time adaptation. Congratulations again for this port and to have included the latest bit perfect Mango firmware by Lurker0 :smile: 

 

Hang on did you just say this latest RB is bundled with Lurker0's latest version of the stock FW?

 

WTB!

post #171 of 1288
Quote:
Originally Posted by headwhacker View Post
 

Here's the latest build. I listened the whole day and didn't notice any crackling noise anymore. Let me know if you still hear any crackling noise.

 

Rockbox_DX90_0_0_8.zip

 

EDIT: I added Lurker0's int V2 mod on this build. :etysmile:

 

:beerchug:

post #172 of 1288
Quote:
Originally Posted by Migou67 View Post
 

 

:beerchug:

 

This is awesome!!

 

I tend to prefer being able to tweak the sound in RB with my JH7 but really like the stock UI with lurkers mods sound with my Grado's.

 

This is truly the best news I have heard 

post #173 of 1288

awesome work headwhacker. thanks for the effort.

post #174 of 1288
Quote:
Originally Posted by headwhacker View Post
 
Quote:
Originally Posted by all999 View Post
 

Still can hear some cracklin, just qieter. I'm not sure about continous play, but there is some crackling for couple seconds after manualy switched tracks.

 



At this point, you have to closely discriminate the actual noise produced by switching tracks and the background noise in the tracks itself. I got a couple of gotchas myself but it turns out it's the noise coming from the track.

At worst, I only get a quick and soft click when switching tracks at the beginning. But not the noise that last a second or longer like what I can easily hear before. I still have not heard the noise while listening to a long playlist or album.

When I test switching tracks in this case I press the prev or fwd button once or twice . In this scenario I have not encounter any noise yet and imo is the best representation of a normal usage.

Also, if you are going to press the prev or fwd button in a very quick succession you are repeatedly forcing rockbox to dump and fill the buffer which increases the chance of hearing a noise. Still not as loud nor last as long as can be heared before.

If you are using a c/iem, a slight movement of your jaw can produce a similar effect or noise so you should be aware of it as well.

 

Sorry, these are the same crackling lasting more than a second. The tracks I've been listening to, are well produced and I know where there are distortions. Hear them on ciems and on K545 as well.

post #175 of 1288
0.0.8 seems to be working fine! smily_headphones1.gif

How long should it take to create the database in rockbox? 15-20 minutes doesn't seem to do the job, it's a 64GB SanDisk card.
post #176 of 1288
Thread Starter 
Quote:
Originally Posted by brinker7 View Post

0.0.8 seems to be working fine! smily_headphones1.gif

How long should it take to create the database in rockbox? 15-20 minutes doesn't seem to do the job, it's a 64GB SanDisk card.

 

It does it in the background I didn't really timed if but it should really not take that long. I have a full 128GB card.

post #177 of 1288
Thread Starter 

Rockbox_DX90_0_1_0.zip

 

New build for today.

 

1. Buffer size set to a fix size. This seems to allow a bigger buffer size.

 

2. Add a few of my favorite themes (CenterArt and iPodWidgets).

post #178 of 1288
Quote:
Originally Posted by headwhacker View Post
 

 

It does it in the background I didn't really timed if but it should really not take that long. I have a full 128GB card.

That's what I thought - seems quite strange. Had it running for a good hour today, whilst it was supposed to create the database in the background - but every time I try to access the database from the menu, it tells me that it isn't initialized...

Will be installing 0.1.0 sometime tomorrow, but doubt that I'll have time to do much testing.

post #179 of 1288
Quote:
Originally Posted by brinker7 View Post
 

That's what I thought - seems quite strange. Had it running for a good hour today, whilst it was supposed to create the database in the background - but every time I try to access the database from the menu, it tells me that it isn't initialized...

Will be installing 0.1.0 sometime tomorrow, but doubt that I'll have time to do much testing.

Did you restart the player? After the initialization of the database, you have to restart the player to access it. Initializing is super fast for me with Rockbox, WAY faster than with Mango.

post #180 of 1288
Quote:
Originally Posted by deho View Post
 

Did you restart the player? After the initialization of the database, you have to restart the player to access it. Initializing is super fast for me with Rockbox, WAY faster than with Mango.

Yeah, had it turned off for some hours now, and just tried turning it on, to no avail.. Still says the database isn't initialized. When I try to initialize, it says "..501 found..." - what exactly is this number? If it's the number of tracks, it's way off, as there's around 2700 tracks on my card.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Rockbox for iBasso DX90 dual boot with Mango (Stock Firmware)