or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Rockbox for iBasso DX90 dual boot with Mango (Stock Firmware)
New Posts  All Forums:Forum Nav:

Rockbox for iBasso DX90 dual boot with Mango (Stock Firmware) - Page 75

post #1111 of 1288
Quote:
Originally Posted by groovyd View Post
 

assuming it also needs #include <stdio.h> up top?

 

does this improve battery life or sound quality at all for you?  the only issue I ever had was a bit of crackling sound after an hour or so of listening which goes away after a re-power.  hopefully this helps with that? is there any way to verify the second core is indeed shut off?


Yes, I guess it needs stdio. Or you can do it rockbox-ish way.

It looks like this helps with cracklings and volume downfalls. Rockbox multithreading is weak on multiple cores, at least with android.

You can read /proc/cpuinfo to view CPU state. There should be an entry for every core of every CPU.


Edited by napka - 11/16/15 at 12:23am
post #1112 of 1288

I have a problem with the WPS screen. I don't know how I changed it but now it shows the on hold screen instead of the normal screen.

 

As an example, I use this theme: http://themes.rockbox.org/index.php?themeid=524&target=cowond2

 

It shows the screen on the right instead of the screen on the left.

 

How can I return to the main WPS screen?

post #1113 of 1288

I've been running rockbox on my DX90 with Napych's latest (from 2015.06.09) as well as the firmware 2.3.0 + L1

 

I have not had any issues with this for some months of regular use, but suddenly in the last week or two, a number of random and very annoying glitches have started popping up regularly:

 

1) When trying to play music files through the USB OTG port, the player has trouble reading them (even though they are in the database) and I usually have to reboot once or twice to get the player to read those files. This problem seems to be worsening with each day. It was never a problem before.

 

2) When I play any album (regardless of where it is stored - USB, internal memory or microsd card) at about 6 seconds into the first track, there is a sudden gap in the playback for about a second.

 

3) The touch buttons (stop, play, etc) on the front of the DX90 randomly stop working and I have to press them 5 - 6 times before they start working again.

 

It's all very strange, none of this was happening before and now suddenly all three of these glitches have started together and are worsening.

 

I tried a factory reset, but it did not change anything.

 

Any other suggestions?

post #1114 of 1288
Quote:
Originally Posted by IainG View Post
 

2) When I play any album (regardless of where it is stored - USB, internal memory or microsd card) at about 6 seconds into the first track, there is a sudden gap in the playback for about a second.

 

When I start an album, there are some pauses in the first 15 seconds

post #1115 of 1288
Heh, it looks it's common problem with ibasso. Few people with dx50 have same problem.
post #1116 of 1288

Great News :)
 

Cheers :)

post #1117 of 1288
Quote:
Originally Posted by IainG View Post
 

Any other suggestions?

Try to move config file somewhere and reboot player to check if it's configuration-related. If it doesn't help, try to re-flash firmware.

post #1118 of 1288
Quote:
Originally Posted by Oletros View Post
 

 

When I start an album, there are some pauses in the first 15 seconds


If you use latest versions, formatting your media and copying music again might help.

post #1119 of 1288

I rememer I had a problem with some albums. It turned out they had a huge cover art images. Try to use default simple theme without cover arts display to find out if it's related to this problem.

post #1120 of 1288
Quote:
Originally Posted by napka View Post
 

Try to move config file somewhere and reboot player to check if it's configuration-related. If it doesn't help, try to re-flash firmware.

Thanks for the suggestions

 

Config.cfg - which is in the .rockbox folder - Where exactly should I move it? Do you mean remove it from the player completely? Move it to another folder on the player?

Let me know and I'll then try both suggestions

post #1121 of 1288
Quote:
Originally Posted by IainG View Post
 

Thanks for the suggestions

 

Config.cfg - which is in the .rockbox folder - Where exactly should I move it? Do you mean remove it from the player completely? Move it to another folder on the player?

Let me know and I'll then try both suggestions


Move it anywhere, so you can restore your settings later.

post #1122 of 1288
Quote:
Originally Posted by napka View Post
 

Try to move config file somewhere and reboot player to check if it's configuration-related. If it doesn't help, try to re-flash firmware.

I tried both of these suggestions. I even deleted rockbox completely from the DX90, and did a fresh download and recopied it to the DX90, re-flashed the latest firmware, factory reset, etc. and nothing has helped.

 

With the USB files - if I go to the "files" section of the menu in rockbox, it can read and play the music files through the USB port - BUT if I try to scan the USB for inclusion in the database, it does not show up in the database, even though when I am selecting the USB files for inclusion in the scanning, it does register that they are there (note that I have done this many times before and it always worked, showing up in my database, it only stopped working a couple weeks ago)

 

I also tried scanning the USB files into the database from Mango, and same thing - it does not include it in the database after scanning.

 

And, the gap in playback at 6 seconds on EVERY album is still there, plus the intermittently non responsive buttons on the front of the player - these two things also showed up at the same time as the USB reading issues, and I never had any these issues before.

 

Very strange. Any other suggestions.

post #1123 of 1288
Quote:
Originally Posted by IainG View Post
 

I tried both of these suggestions. I even deleted rockbox completely from the DX90, and did a fresh download and recopied it to the DX90, re-flashed the latest firmware, factory reset, etc. and nothing has helped.

 

With the USB files - if I go to the "files" section of the menu in rockbox, it can read and play the music files through the USB port - BUT if I try to scan the USB for inclusion in the database, it does not show up in the database, even though when I am selecting the USB files for inclusion in the scanning, it does register that they are there (note that I have done this many times before and it always worked, showing up in my database, it only stopped working a couple weeks ago)

 

I also tried scanning the USB files into the database from Mango, and same thing - it does not include it in the database after scanning.

 

And, the gap in playback at 6 seconds on EVERY album is still there, plus the intermittently non responsive buttons on the front of the player - these two things also showed up at the same time as the USB reading issues, and I never had any these issues before.

 

Very strange. Any other suggestions.

+1 did almost exactly the same thing and the 6 seconds happens to me, albeit randomly.  Same goes for the unresponsive buttons, though for 2-3 seconds randomly as well.

post #1124 of 1288
Quote:
Originally Posted by Guppy_ View Post
 

+1 did almost exactly the same thing and the 6 seconds happens to me, albeit randomly.  Same goes for the unresponsive buttons, though for 2-3 seconds randomly as well.


sounds like a hardware problem queueing up the track must be a bad flash card.  I would return it for a full refund.

post #1125 of 1288
Quote:
Originally Posted by groovyd View Post
 


sounds like a hardware problem queueing up the track must be a bad flash card.  I would return it for a full refund.

My version of this problem just randomly popped up after over a year of flawless performance. Bad news, as my players is past the warranty coverage date (assuming it is one year) and I am currently living in an obscure part of the planet where returning it would be next to impossible :(

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Rockbox for iBasso DX90 dual boot with Mango (Stock Firmware)