Head-Fi.org › Forums › Misc.-Category Forums › Feedback & Bug Reports › Disallowed Key Characters
New Posts  All Forums:Forum Nav:

Disallowed Key Characters

post #1 of 4
Thread Starter 

Problem: When trying to log in, or access the login page, or turn off particular add-ons (will go into more depth later) after having been logged in for a while, it results in a blank page with the error message "Disallowed Key Characters" and any subsequent attempts to access a page when logged in results in the same error.

 

Steps to troubleshoot: When I had encountered this error I had simply assumed that this was a problem with Tor. Now I know what you're going to say; why on earth are you doing casual browsing through Tor? The reason being that I have been trying to muster up a personal project of mine that involves a very convoluted setup in a VM, which includes Tor. Therefore it is sometimes useful for me to have my daily browser on Tor. I usually turn it off but on some particular sessions I forget. On this occasion this was the case so I immediately stopped using the SOCKS proxy and went on my merry way.

 

At first I thought this had solved my problem but a few days later I found that this problem persisted with or without Tor. I put in a bit more thought to the error message, and realized that it could very well mean that, quite literally, that the characters in my password had gone through some strange formatting in the clipboard. I have a rather large (50-60 character) password that I use so that I will have no hopes of memorizing it and would therefore be unable to log in and waste endless amounts of time outside of the house. I keep it in my clipboard for pasting later.

 

Now this process had never caused a problem for me in the several years that I have had this account. The characters are fairly simple ASCII characters, and while my clipboard (xcmenu, which is basically xclip with extra niceties like a dmenu interface) has had its share of formatting problems in the past, especially with adding whitespace, the password was a fairly simple affair.

 

Nevertheless I ended up typing the password by hand (which I never want to do again, especially having ended up doing it 12-13 times) and the error had not occurred. I thought that I was in the clear.

 

I typically run Adblock Plus with an element hider as the ads and many of the elements on Huddler sites I find terribly intrusive. A few days ago I wanted to check the sidebar (which I usually have hidden) because of the gallery preview for the thread is located there. To my disbelief I was met with that pesky key character message again, and was unable to access the site while logged in.

 

This is where I started to test under every condition imaginable. First I tried logging in to, with or without all add-ons (the important ones includes ABP, Noscript, RequestPolicy, Scriptish, HTTPS Everywhere, and Pentadactyl), with or without browser data such as cache and cookies, on a private browsing profile, and on a totally clean profile I keep for testing on just these occasions, with absolutely default settings on everything. My primary browser is a build of Firefox called Palemoon, which is essentially Firefox 24 with some compiler optimizations. The build has pretty sane defaults so I doubt that the browser is the issue. I have also tried logging in through Chrome/ium, every and all Webkit broswers imaginable, Opera, heck even IE (on a very old XP VM). The only thing that ended up not giving this error consistently was w3m, most likely because it is a text-based browser with no JavaScript and most of Huddler's woes come from the dreaded `Script. I have also tried various machines to no avail.

 

After going through the steps, I am emphatically positive that there should be nothing wrong on my end, at least userland-wise. The problem could be isolated to my location alone (at first I thought I had been banned which confused me to no end). I have not tried logging in through another network, for the reasons that I had mentioned above (a very long password). I will have to try this for sure. Although considering what Tor is....

 

I have started the process of actively debugging this in a serious fashion, looking through Firebug, etc, not just trying various browser environments and I will try to document this as I go. However, as I am used to with Huddler, it is very difficult to get anywhere without the staff actually taking a look at the inside. I would normally deal with this, sound and sight unseen, but due to the fact that I have seen mentions of this error on one or two other threads on H-F, and numerous others on other Huddler-run forums such as Overclock.net and the likes, I have decided that I might see if others are going through the same woes as I am. It is likely that the message itself is rather generic, but the cause leading to the recent influx of problems is something peculiar to Huddler itself.

 

I find this troublesome because at this point it is very difficult to have a session on Head-Fi without the error rendering me unable to access any other page while logged in, and I have to clear my browser session and bang on every single possible fix until it decides to log me in with no problems (but for how long is always uncertain).

 

 

...

 

 

If anyone has had this problem occur to them please chime in, and if the staff might have any clues as to why this is a problem it would be much appreciated. I will fill in an actual bug report, and possibly to Huddler, although for the latter I am not sure as to how I might do so.

post #2 of 4

@TwinQY - Can you post a screenshot showing both the error and the address bar contents?  

post #3 of 4
Thread Starter 

It has not managed to replicate itself today so I do hope that it has resolved itself magically. If it does come up however I will most definitely take a screenshot. I think the URLs always end up simply being that of the page I am trying to access, except that the error message shows instead of the page being displayed .

post #4 of 4
Thread Starter 

It seems to have stopped entirely. If it comes back I might chime in again but I guess some magic happened behind the scenes.

 

I see another thread with the person experiencing same error message that was made before mine and I guess I probably should have checked in there before I started this thread. Feel free to merge.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Feedback & Bug Reports
Head-Fi.org › Forums › Misc.-Category Forums › Feedback & Bug Reports › Disallowed Key Characters