or Connect
Head-Fi.org › Forums › Misc.-Category Forums › Video Games Discussion › Help with PS3 Optical!!
New Posts  All Forums:Forum Nav:

Help with PS3 Optical!!

post #1 of 3
Thread Starter 

So i got me the Creative SoundBlaster X-Fi HD for use with my laptop and speakers, and the headphone amp for my Superlux HD-668B  . It has a Optical in and out, and I thought to myself,,, DUR I CAN USE THIS THING TO HOOK UP MY HEADPHONE TO PS3 WHEN I DON'T WANNA DISTURB THE WHOLE HOUSE, BRILLIANT 

-So I hooked it up. Set the PS3 to output through optical. It Chose what should be the proper LPMC settings ( 2 channel 44.1 and 48 kHz)

-I hear the menu clicks as I zip around the XMB... YAYYY!!

-I try to play music saved on my HDD. NOTHING 

-I try to play videos on the HDD. FLAWLESS 

-I play a CD. FLAWLESS

-Oh and no Blu-Ray audio output either

-I play a game. NOTHING???  What on earth is this shenanigans

I tried turning off bitstream and that didn't help. the same thing, what plays works and what doesn't work just doesn't

I'm perplexed. Might anyone have any experience with this set-up or know more about the PS3s handling of different audio playback assistance would be greatly appreciated. Since it's half working I've done something semi right (i think)

 

If nothing else, can someone please recommend a DAC/Amp/combo to use with my PS3.

post #2 of 3
Quote:
Originally Posted by D3Seeker View Post
 

So i got me the Creative SoundBlaster X-Fi HD for use with my laptop and speakers, and the headphone amp for my Superlux HD-668B  . It has a Optical in and out, and I thought to myself,,, DUR I CAN USE THIS THING TO HOOK UP MY HEADPHONE TO PS3 WHEN I DON'T WANNA DISTURB THE WHOLE HOUSE, BRILLIANT 
-So I hooked it up. Set the PS3 to output through optical. It Chose what should be the proper LPMC settings ( 2 channel 44.1 and 48 kHz)
-I hear the menu clicks as I zip around the XMB... YAYYY!!
I try to play music saved on my HDD. NOTHING 
-I try to play videos on the HDD. FLAWLESS 
-I play a CD. FLAWLESS
-Oh and no Blu-Ray audio output either
-I play a game. NOTHING???  What on earth is this shenanigans
I tried turning off bitstream and that didn't help. the same thing, what plays works and what doesn't work just doesn't
I'm perplexed. Might anyone have any experience with this set-up or know more about the PS3s handling of different audio playback assistance would be greatly appreciated. Since it's half working I've done something semi right (i think)

If nothing else, can someone please recommend a DAC/Amp/combo to use with my PS3.

 

I'm not sure Creative Labs has any driver that allow the X-Fi HD to work with the Sony PS3.

Check out the Astro mix-amp.

post #3 of 3
Thread Starter 

Hmm. Shall do I suppose.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Video Games Discussion
Head-Fi.org › Forums › Misc.-Category Forums › Video Games Discussion › Help with PS3 Optical!!