New Posts  All Forums:Forum Nav:

No Audio Through Dac/Amp

post #1 of 11
Thread Starter 

I am using the Xonar DG with my Schiit Magni/Modi which connects to my HE400s. I have it set up like this so I can use dolby headphone as well as a dac/amp, but let's cut to the chase. Last night my headphones were working fine, but when I get on my computer today and go to watch netflix they aren't working. I have already confirmed it's not my headphones by using them with another device. I also have another set of headphones connected to my soundcard via a 3.5mm jack. So my soundcard is outputting audio, but idk if it's outputting a digital signal to my dac/amp. Any help would be greatly appreciated! 

post #2 of 11
Quote:
Originally Posted by DanielMiracle View Post
 

I am using the Xonar DG with my Schiit Magni/Modi which connects to my HE-400s. I have it set up like this so I can use Dolby Headphone as well as a dac/amp, but let's cut to the chase. Last night my headphones were working fine, but when I get on my computer today and go to watch Netflix they aren't working. I have already confirmed it's not my headphones by using them with another device. I also have another set of headphones connected to my sound card via a 3.5mm jack. So my sound card is outputting audio, but idk if it's outputting a digital signal to my dac/amp. Any help would be greatly appreciated! 

 

Hopefully you have disabled the motherboard's on-board audio? in the BIOS.

 

Try installing the "Unified Xonar Drivers", clean install.

http://maxedtech.com/asus-xonar-unified-drivers/

post #3 of 11
Thread Starter 
Quote:
Originally Posted by PurpleAngel View Post
 

 

Hopefully you have disabled the motherboard's on-board audio? in the BIOS.

 

Try installing the "Unified Xonar Drivers", clean install.

http://maxedtech.com/asus-xonar-unified-drivers/

I've done both. What should I do now?

post #4 of 11
What is your default play back device in Windows? If it is the analog out on your onboard audio chip you need to change it to the USB on your dac. (or coax or optical)

Sent from my Nexus 5 using Tapatalk
post #5 of 11
Thread Starter 
Quote:
Originally Posted by jellowiggler View Post

What is your default play back device in Windows? If it is the analog out on your onboard audio chip you need to change it to the USB on your dac. (or coax or optical)

Sent from my Nexus 5 using Tapatalk

I set it to my sound card before, but I tried bypassing it and setting it as the "optical pass through device" (I believe that was what it was called) to use the dac/amp only, but that didn't work either.

post #6 of 11
Quote:
Originally Posted by DanielMiracle View Post
 

I set it to my sound card before, but I tried bypassing it and setting it as the "optical pass through device" (I believe that was what it was called) to use the dac/amp only, but that didn't work either.

Your play back device should be your Xonar DG.

Can you check Modi with any other device outputting optical (TV, DVD player, game console etc) ?

post #7 of 11
Thread Starter 
Quote:
Originally Posted by i019791 View Post
 

Your play back device should be your Xonar DG.

Can you check Modi with any other device outputting optical (TV, DVD player, game console etc) ?

I tried it on my ps3, but I really have no idea how to set it up with that. I didn't hear audio through it, but that could have just been my fault. 

post #8 of 11
Quote:
Originally Posted by DanielMiracle View Post
 

I set it to my sound card before, but I tried bypassing it and setting it as the "optical pass through device" (I believe that was what it was called) to use the dac/amp only, but that didn't work either.

 

Is the optical output enabled (PCM?) in the Xonar DG's control panel?

post #9 of 11

See:

 

https://support.us.playstation.com/app/answers/detail/a_id/788/~/change-ps3-audio-output-settings

 

It seems you should try with a plain CD on PS3.

 

I suppose you have checked that the interconnects from Modi to Magni are plugged properly.

 

You may first check the Magni from any analog source, including your Xonar DG I suppose


Edited by i019791 - 6/15/14 at 3:11pm
post #10 of 11
Quote:
Originally Posted by DanielMiracle View Post
 

I set it to my sound card before, but I tried bypassing it and setting it as the "optical pass through device" (I believe that was what it was called) to use the dac/amp only, but that didn't work either.

 

Maybe the Xonar DG is broken?

 

Does your motherboard come with optical output?

If so, remove the Xonar DG and Asus/Unified software.

Enable on-board audio in the BIOS.

Update to the latest drivers for on-board audio.

Test Modi/magni.

post #11 of 11
Thread Starter 

So I finally fixed it. When I reinstalled the drivers, I installed the latest ones. What fixed it for me was reinstalling an older driver version.

New Posts  All Forums:Forum Nav:
  Return Home