or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Sennheiser Momentum and O2/ODAC Issue
New Posts  All Forums:Forum Nav:

Sennheiser Momentum and O2/ODAC Issue

post #1 of 2
Thread Starter 

Hey everyone,

 

I recently got the momentums and like them a lot so far. My major issue is with the mic/control cord. I have seen others speak of degraded sq with it but my experience is specifically with using it with my JDS O2/ODAC hooked up to my computer.

 

When I plug in the phones to the O2/ODAC using the mic/control cord they behave strangely. It seems like only part of the signal is coming through. Think no bass line and overall low volume. This does not happen with the mic cord into the iphone or directly into the PC headphone jack. The no mic cord does not have any of these issues.

 

Does anyone have any thoughts on this issue? Trying to decide if I should return the headphones (which I don't really want to do) or go through sennheiser knowing how expensive this cord is to replace (~160 bucks i have heard).

 

Or maybe it is just a general issue with these types of mic cords and the O2/ODAC that people know about.

 

Thanks all.


Edited by thecostanza - 6/1/14 at 3:58pm
post #2 of 2
Thread Starter 

Also forgot to mention when the mic cord is in the o2/odac it does work if I spin it around just the right way.

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Sennheiser Momentum and O2/ODAC Issue