or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › silly question i'm sure but still...
New Posts  All Forums:Forum Nav:

silly question i'm sure but still...

post #1 of 6
Thread Starter 

using a creek obh-21se with a denon adh5000.

 

this is the Q ; why do i hear sound from both channels on my headphones when i unplug one of the RCA cables ? am i not correct in assuming i should just hear one ear? i thought it might be the amp or source causing it but after switching them out too i still have the same result. Even tried with a schiit magni. My iphone 5s delivers a better sound stage then this set up. kinda weird. I've heard of crossfeeding but didn't think that means flattening the entire image. Apologies for my spelling... And ta very much for any thoughts...

post #2 of 6
Quote:
Originally Posted by KingMonkey1977 View Post
 

using a creek obh-21se with a denon adh5000.

 

this is the Q ; why do i hear sound from both channels on my headphones when i unplug one of the RCA cables ? am i not correct in assuming i should just hear one ear? i thought it might be the amp or source causing it but after switching them out too i still have the same result. Even tried with a schiit magni. My iphone 5s delivers a better sound stage then this set up. kinda weird. I've heard of crossfeeding but didn't think that means flattening the entire image. Apologies for my spelling... And ta very much for any thoughts...

have you had any mods done to your D5k? 

post #3 of 6
Thread Starter 

no its all stock. the part i dont get is that the amp delivers more bass and fuller sound than an iphone but the imaging is total snot.

post #4 of 6
Quote:
Originally Posted by KingMonkey1977 View Post
 

no its all stock. the part i dont get is that the amp delivers more bass and fuller sound than an iphone but the imaging is total snot.

In that case it might be your headphone cable, I had my D2k recabled and it wasn't terminated correctly, so there's a chance there is a malfunction in your headphone cable causing you to get Mono Sound out of your headphone, as opposed to Stero

 

if you can afford it, contact Brian at BTG, he might be able to take a look at your headphone, and if it needs a cable he can build a new one for around $50 or so 

post #5 of 6
Thread Starter 

I was thinking in that direction too.. maybe its the source ( arcam cd92 ) its getting up there in age. The only reason im thinking its not the headphone at all is that it sounds awesome on a dragonfly USB dac. 

 

Thanks for the response.

post #6 of 6
Quote:
Originally Posted by KingMonkey1977 View Post
 

I was thinking in that direction too.. maybe its the source ( arcam cd92 ) its getting up there in age. The only reason im thinking its not the headphone at all is that it sounds awesome on a dragonfly USB dac. 

 

Thanks for the response.

If the headphone sounds fine on another source then it could be your amp or your dac 

 

thinking a little more about it all, it could be that your amp  is creating some kind of cross over in the channels within the amp it self 

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › silly question i'm sure but still...