or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Foobar2k doesn't see my shared drive
New Posts  All Forums:Forum Nav:

Foobar2k doesn't see my shared drive

post #1 of 14
Thread Starter 

I wonder if someone can help with this problem.  I had no problems streaming with Foobar on a laptop from a shared network drive located elsewhere to my Oppo 103.

But starting yesterday it won't "see" the network drive at all.  I've tried restarting both the laptop and main computer. I've also tried uninstalling and reinstalling the UPnP component.  Nada.  This is before I have it try to find the Oppo.  I just try to have the Foobar load a music folder from the networked drive, but something it used to find without difficulty is now invisible to Foobar.

 

Any ideas what I should try?

 

Thanks.

post #2 of 14

Are you able to access your shared network drive directly from the explorer of your laptop ?

Try to access your shared drive directly by its address ("\\My-Computer\My-Disk")

If not, according to the error, you'll have to check both the access policies and the right management policies from your main computer (and it can be quite annoying, policies are dispatched in several configuration consoles).

You can also start by the beginning :

  1) check if you can reach one computer from the other (in both way, with a ping on both side)

  2) If yes, check if you can reach the shared hard drive from your laptop (without using foobar)

  3) If yes, it means it's a foobar configuration problem, but i bet the problem comes from a lower level, configurations don't change randomly (at least without human/vicious code modification, or nice update sometime)

If you need more, please tell us you main computer's OS, and you network configuration for your two computer to reach each other (through LAN, VPN, WAN...)

post #3 of 14
Thread Starter 

Hi. I've found out that it's a problem with the laptop connecting to the networked computer.  It doesn't see it.  I've tried inputting the IP address directly but it doesn't work. Also I checked the sharing options on such for the desktop and other machines can see it.

 

Then I tried doing a system restore on the laptop but it won't complete.  It always says there's some kind of error with extracting C:  Sounds like I'm hosed and may need to do a complete reinstall of windows.  Frankly, I don't have the time to do this garbage.  Quite frustrating if you ask me.  No idea how this could happen.

post #4 of 14

Could you give me the exact error message you're getting while restoring, it may be not necessary to do a complete reinstall of windows (btw, which windows is it ?)  

post #5 of 14
Thread Starter 

I tried another restore today. This is the error message I got:

 

System Restore failed to extract the file (C:\) from the restore point.  An unspecified error occurred during System Restore. 0x8000ffff

 

It's the same error every time no matter which restore point I  select.  What can I do?

 

Thanks.

post #6 of 14

I bet you're running on Windows 7 :wink_face:

Don't worry, no big deal here...

This error is well known, and has been considered not to be hazardous for your data.

 

So First of all try this workaround : 

1 On Windows, launch the "System Restore" app. AS ADMINISTRATOR (you can find it with the search box of the start menu).
2 Click next in the dialog box, then select a restore point and click next again. Finally click  on "finish" in the confirmation window.

 

If it doesn't work or you want to solve the trouble for the next time,
you must apply a hotfix package from microsoft you can find in the Microsoft Knowledge Base article 2709289.

 

By the way, you might have other option than a system restore to fixing your network problem. Here's some test to do (after you've fixed the 

trouble above and if you are still not able to reach your shared volume) :

First of all, check that a ping from an other device to your main computer hosting the shared volume work (need a working reference to consider the tests results)

then test a ping from you're laptop to your main computer.

If it doesn't work, it means its a network setting problem. You might check your network configuration to verify your laptop & your main computer are connected to the same network (meaning same network address,  same subnet mask, different IPs)

If you're connected (you got internet, and check the settings above) but ping doesn't, you have to investigate using a network analyzer (eg Wireshark)

If you're connected and ping works, it comes from higher levels network layer

You should check you're sharing the same network domain.

You can check if you can reach your main computer with the console command "net view \\Main-Computer-name" or "net view \\Main-computer-IP". 

post #7 of 14
Thread Starter 

Thanks very much.  Yes, I'm running Win 7 (forgot to mention this).  The workaround let me system restore and then after that it recognized the drive and we're back up.  So what should I do in the future to forestall this problem?

 

Thanks again for giving such detailed help.  I'm always bewildered by the variety of network issues that arise.

post #8 of 14
Thread Starter 

And the Foobar Upnp still doesn't see the Oppo!!  I have no idea what the deal is.  The computer sees the network. I can load files into Foobar, but the Upnp browser doesn't see the Oppo 103.  It used to go in and out, but a reset of the Oppo would fix that.  But now, it just doesn't see it at all.

 

I'm really beginning to think the Oppo software is a lemon.  It's a great CD player but its usb system and streaming capabilities are crappy.  And of course its Ipad controller app is famously buggy. 4 out of 5 times it'll disconnect in the middle of playing something.

 

This is totally frustrating, especially since I run the Oppo without a tv screen for audio only.  And its main controls are screen based unless you use Upnp or the Ipad app.

post #9 of 14

About the System Restore problem on Win. 7, go to support.microsoft.com/kb/2709289

You'll find the hotfix to download and the whole procedure to fix the problem definitively.

 

For Foobar using your Oppo through UPnP :

The issue can either comme from Foobar/Win7 or your Oppo itself (or both).

If you are able to control your Oppo (I mean access the drive through UPnP and play music from it) from an other device, it definitely comes from Foobar

(However, definitely is not a word I use with computer, we never know every details)

 

- So First of all, assure that Foobar is allowed to access network by checking your firewall's rules.

- Foobar has no settings for UPnP (it makes a little bit of sen, UPnP Has been done for that) So one thing you should do :

   Uninstall Foobar (completly).

   Install the last version, 

   Add the "UPnP MediaRender Output" & The "UPNP/DNLA Renderer,Server,Control Point" components

   At that point, win7 should ask you if you want to allow Foobar to access network. You might want to check if win7 consider your local network as "home" or "outside" (from the network center in

       control panel). Accept foobar to access network, either home or home & outside.

   IF win7 didn't ask you anything -> Checking firewall rules is mandatory (and the real ones you can access from the "advanced options" in your firewall control center

   Check it.

 

If everything seems all right, then it's time to check out you Oppo.

Start with checking if your Oppo has done an firmware update recently. You might not be able to see the last update

(I don't know the Oppo 103).

Check the Oppo settings to (Again, if it works from an other device, It should work from Foobar, UPnP has been designed on the purpose)

Finally, if Oppo has been updated recently, you might try to go back to the previous firmware, it could be an implantation bug (I'm not sure if it's possible to do that on that device).

 

Hope you'll good with that (otherwise, gonna be tricky)

post #10 of 14

Oh I forgot about your Oppo's setting to check :

In the Settings menu go to the network setup :

   - My Network should be ON 

post #11 of 14
Thread Starter 

Thanks very much.  I think this must be something with the Oppo.  I turned it on and off a few times and then Foobar saw it the next day.   It's frustrating because it doesn't seem to play well either with Upnp or even its own Ipad control app.  The latter will often lead to a freeze in the middle of an album and then the Oppo becomes unresponsive to both the Ipad app and its physical remote control.

post #12 of 14
Humm, do you know if anyone else have been experimented the same trouble with the oppo ?
Oh btw, i'm not sure if I got exactly how you play your music so please tell me if I'm wrong

Laptop/Ipad : control the remote hard disk & the Oppo through network (access the hard disk, control the playback)
Hard disk : connected by USB to an other computer
Oppo : plays the music on your HiFi system (on that point, I might be wrong, do you also want to stream the music back to your laptop / Ipad ?)

Try to play a album (who usually crashes) directly on to the oppo through a usb key, If it works (and it should) its a network problem (bandwith, connectivity...)
Check play that album directly from your laptop (without passing through the oppo) (and do that close to your oppo if you are using wifi). It it doesn't work,
it's a wifi problem. If it work, then yes its comes from you oppo's firmware implantation, or the oppo's hardware itself.
post #13 of 14
Thread Starter 

Thanks.  Here's the way I play things on the Oppo.

 

Aside from physical discs, I either a) use a laptop and stream music from a hard drive located elsewhere to the Oppo using Foobar or b) connect a physical hard drive or flash drive to the Oppo and control playback using Oppo's Ipad app.  I listen to Spotify sometimes, but haven't found a convenient way to play it on the Oppo except with a physical cable from computer to player but that's inconvenient as I sit 12 or more feet away.

 

On my desktop, I listen using a Dragonfly -> Headphone amp -> Sennheiser HD600.

 

All my problems come from dealing with the Oppo.  There are many complaints about the Ipad app. I've called Oppo and they acknowledge that it has problems and that's also reflected in several reviews in the Ipad app shop.

post #14 of 14
IMHO If you have trouble listening music from your Oppo even when your hard drive if plugged on it without using Ipad app, I'm afraid you're stucked waiting for a firmware update to solve the problem.
If you don't experiment such a trouble, but only when using Ipad app it may either comes from the Oppo itself or the App. Because you're also having trouble with using it through Foobar, I would say
it comes from the Oppo itself not being good as being remotely managed.

I hope they will correct that quickly, if you want to keep your Oppo.

However, if you'd like to have an audio server dedicated to your hifi,
with the opportunity to play music from network storage, Spotify or others streaming sources,
you have good alternatives, like a microcomputer (or an old recycled one) set up with a music server software.
You can even find dedicated free OS for that (eg. Daphile) which work pretty much on any configuration.
You have also very good project for single-board computer like raspyFi (audio server dedicated for raspberry pi) or Google Chromecast.

I'm using at home raspyFi, and that's a well advanced project, very simple to setup. Because it's based on linux' music player daemon,
you have a bunch of applications to control it remotely (Mpad for IPad is one of them very well made btw) and will be able to play music from Sptoify, Nas...)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Foobar2k doesn't see my shared drive