Head-Fi.org › Forums › Head-Fi Special Forums › Premier Sponsor Forums and Sponsor Forums › Sponsor Forums › FiiO › Reference table for album art, tagging and lyrics support on the X3 and X5
New Posts  All Forums:Forum Nav:

Reference table for album art, tagging and lyrics support on the X3 and X5 - Page 4

post #46 of 58
Quote:
Originally Posted by tjw321 View Post

Is cover.jpg not working even on 2.20?

I'm about to test this out.

Just finished adding 500x500 cover.jpg album art to every album i have on the X5. Most in flac, one in mp3, several in m4a/aac. I'll update this post in a bit.
post #47 of 58
Quote:
Originally Posted by tjw321 View Post

Quote:
Originally Posted by Poimandres View Post

Nope. Something as simple as album art too.

Is cover.jpg not working even on 2.20?

It's certainly working with flac
post #48 of 58
No question it works with flac.
post #49 of 58
Quote:
Originally Posted by Poimandres View Post

No question it works with flac.

I've been thinking.

Is there album art already embedded in the ogg files?
I think the X5 tries to read them, fails, and thus doesn't read the external cover.jpg files?
post #50 of 58
Quote:
Originally Posted by Poimandres View Post

No question it works with flac.


You have said that you have embedded art with .ogg when this isnt supported.

Embedded art takes precedence over cover.jpg - so does cover.jpg work with .ogg in 2.2 that doesn't have embedded art?

Maybe the prsence of the embedded art is blocking cover.jpg as it would with .flac files.

post #51 of 58

FiiO X1 can support lyric?

post #52 of 58

So I recently purchased an X5 and though I'm very happy with it, I am having trouble with SOME album art on FW 2.4.

 

Most folders/albums show the cover.jpg file perfectly, with no trouble. But a handful of folders don't show anything, and I just get a black image. For example, Shakey Grave's "Roll the Bones" (available on band camp: https://shakeygraves.bandcamp.com/album/roll-the-bones , posted the link for reference, I'm using the MP3 version) doesn't show anything, even though it comes with a cover.jpg file. I've tried embedding the album art directly into the MP3, I've tried having cover.jpg , folder.jpg , album.jpg , but nothing has worked.

 

Is someone else having a similar issue, some album art just doesn't show up, even though most do? Is there something I can do?

post #53 of 58
Quote:
Originally Posted by tapanther View Post
 

So I recently purchased an X5 and though I'm very happy with it, I am having trouble with SOME album art on FW 2.4.

 

Most folders/albums show the cover.jpg file perfectly, with no trouble. But a handful of folders don't show anything, and I just get a black image. For example, Shakey Grave's "Roll the Bones" (available on band camp: https://shakeygraves.bandcamp.com/album/roll-the-bones , posted the link for reference, I'm using the MP3 version) doesn't show anything, even though it comes with a cover.jpg file. I've tried embedding the album art directly into the MP3, I've tried having cover.jpg , folder.jpg , album.jpg , but nothing has worked.

 

Is someone else having a similar issue, some album art just doesn't show up, even though most do? Is there something I can do?


Is the cover.jpg within the supported size? If it is, it may be corrupt and simply renaming it or embedding it will not change that. Try resizing it - that way the file will be rebuilt.

post #54 of 58

Hi uzi2,

 

The cover.jpg is within the supported size, 500x500px jpeg file. I tried resizing it to 400x400, but I still get a black image. I had also tried converting it to png, but that also didn't do anything. I don't see anything fundamentally different between this album art and others that do work perfectly fine. I do appreciate the suggestion, I hadn't thought of resizing it to test. Perhaps there's more requirements that I'm unaware of, or it could be a strange bug in the firmware. If I could post attachments (too new to the forumns =P) I'd attach the cover art here just to see if it's my unit, or all units.

post #55 of 58
Quote:
Originally Posted by tapanther View Post
 

Hi uzi2,

 

The cover.jpg is within the supported size, 500x500px jpeg file. I tried resizing it to 400x400, but I still get a black image. I had also tried converting it to png, but that also didn't do anything. I don't see anything fundamentally different between this album art and others that do work perfectly fine. I do appreciate the suggestion, I hadn't thought of resizing it to test. Perhaps there's more requirements that I'm unaware of, or it could be a strange bug in the firmware. If I could post attachments (too new to the forumns =P) I'd attach the cover art here just to see if it's my unit, or all units.


Yes - it would be good to be able to test it...

The sinmplest solution is to download the cover from elsewhere and use that, but it would be nice to know what's causing the problem.

post #56 of 58
Quote:
Originally Posted by tapanther View Post
 

Hi uzi2,

 

The cover.jpg is within the supported size, 500x500px jpeg file. I tried resizing it to 400x400, but I still get a black image. I had also tried converting it to png, but that also didn't do anything. I don't see anything fundamentally different between this album art and others that do work perfectly fine. I do appreciate the suggestion, I hadn't thought of resizing it to test. Perhaps there's more requirements that I'm unaware of, or it could be a strange bug in the firmware. If I could post attachments (too new to the forumns =P) I'd attach the cover art here just to see if it's my unit, or all units.

I think I read somewhere that someone was having issues with grayscale jpegs. These wouldn't be B&W images, would they?

post #57 of 58
Quote:
Originally Posted by tjw321 View Post
 

I think I read somewhere that someone was having issues with grayscale jpegs. These wouldn't be B&W images, would they?

Yes it is! I did try saving it with color information (saved in photoshop after changing the color mode, the original was in grayscale mode). Let me see if colorizing it does anything. But yes, the image is in black and white.

post #58 of 58

Woops, wrong thread.... Sorry!


Edited by Rastpokruczltan - 4/1/15 at 3:19pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: FiiO
Head-Fi.org › Forums › Head-Fi Special Forums › Premier Sponsor Forums and Sponsor Forums › Sponsor Forums › FiiO › Reference table for album art, tagging and lyrics support on the X3 and X5