or Connect
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Help with my Rega RP3, problem with motor frequency
New Posts  All Forums:Forum Nav:

Help with my Rega RP3, problem with motor frequency

post #1 of 4
Thread Starter 

I just got my RP3 off ebay yesterday.  The supplied powersupply is a ac adaptor 120v and 24v 100ma output at 60hz.  The problem is my motor after pulling the cover off is a 50hz motor.  Combined this resulted in a 20% increase in TT speed.  My question is would this ac adaptor pictured, adequately supply the motor without damage?

post #2 of 4

The transformer won't change the frequency for you. If the motor is 50Hz, check if it has some sort of adjustment to make it compatible with 60Hz operation. Contact Rega Support for help is my best advice since they would know a lot more.

I don't trust the 100mA transformer as far as using it with the TT is concerned. I would expect it to be more than 100mA.

post #3 of 4

You may need to order a 60hz motor from Rega.

post #4 of 4
Thread Starter 
I actually got quite lucky. The man I bought it from received it brand new from a legit Rega dealer--however he was mistakenly sent a 50hz euro model. For some reason unbeknownst to me he never tested or used it before reselling it to me. After some phone calls the rep that sold it to him agreed to sell me the RP6 TT-PSU which operates correctly at 50hz for a 50% discount($200). So in the end I got a brand new RP3 with PSU for less than the price of a new one still.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Help with my Rega RP3, problem with motor frequency