or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Have some problems with my turntable setup..Need Help!
New Posts  All Forums:Forum Nav:

Have some problems with my turntable setup..Need Help!

post #1 of 6
Thread Starter 

sup everyone,

 

I have a Rega RP3 and Jolida JD9II phono stage(btw I'm new to this category) after I set up the turntable and connected all the components and fire the power button,

there is a really dominating hum or noise coming out of the speakers, the music is there but it gets buried by the noise,

 

since I'm new to LP listening, I was wondering did I put too much weight on the stylus, or it is because I haven't grounded the phono stage? or it could be that my integrated amp is too old(15 years+) that some of the components don't work properly?

 

I really appreciate if you guys can diagnose this for me, perhaps give me something to try, I really want to fix this

 

My setup:

 

Rega RP3 + Elys 2
Jolida JD9II (not ground, default setting on the back panel)

Sony Integrated amp (probably 18 years old, it's working fine in terms of playing CD or Radio tho)

post #2 of 6
Ground it! Required on all turntables to avoid loud hum.
post #3 of 6

+1 It's a grounding issue most likely. 

post #4 of 6
Thread Starter 

excuse my dumb question, how do I ground it? Do I need to ground it between phono preamp and turntable? seems like my turntable doesnt have any place to ground and it doesnt come with grounding wire also 

post #5 of 6
Quote:
Originally Posted by graphic View Post
 

excuse my dumb question, how do I ground it? Do I need to ground it between phono preamp and turntable? seems like my turntable doesnt have any place to ground and it doesnt come with grounding wire also 

Not a dumb question.  Generally, all turntables come with a 3rd connection (in addition to the 2 connections for right and left audio channels) which is usually a set screw type connector for attaching a thin ground wire between the turntable and the phono preamp (or preamp or integrated amp).  That's almost always true -- but now I see that Rega does it differently.  Apparently they connect the ground through the internal shielding in the right and/or left audio channel cables.  Hmm.  Any Rega owners out there with comments?

post #6 of 6
Thread Starter 

Thanks a lot Bill, I did some google search, Rega does ground their turntable internally, 

 

there is another fact that I found, when I adjust the volume nob on my integrated amp, the hum changes, its all random, sometimes the hum is severe, sometimes mild, its all depends how I adjust the volume, and sometimes music comes through both speakers sometimes only comes from either one of the speakers, I guess maybe my system is too old that some of the components are getting old, my Sony integrated amp is like 18ys old, and its really cheap now on ebay(80 bucks or so)

 

i'll see if I can borrow an amp from my friend and see what will happen

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Have some problems with my turntable setup..Need Help!