or Connect
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Stax SR 507 channel imbalance
New Posts  All Forums:Forum Nav:

Stax SR 507 channel imbalance

post #1 of 8
Thread Starter 

Until yesterday this unit was exemplary.  The driver unit is a Stax SRM 323 S.  I've had these phones for a few months and the audio just seemed to get better and better.  Today, the right channel audio was much less than the left channel. Also, the audio quality in general has deteriorated.  I tried to compensate by turning the right gain higher, but this has resulted in distortion of the right channel.  Obviously, this cannot go on.  The phones were purchased from PriceJapan so should be under warranty since the purchase date was less than a year ago.  I just sent PriceJapan a message.  Has anyone here had a similar experience, and what were the results?


Edited by glorkaglickflic - 4/10/14 at 10:24am
post #2 of 8

Parasitic charge.

 

You can play around with plugging them in/out of the driver unit (shorting out the pins with your finger each time).

 

In my experience the only long-term solution is to stow the headphones away for at least a week (a month would be ideal) to completely discharge the diaphragms and render a more permanent solution.

post #3 of 8
Thread Starter 

I'm taking your suggestion, first of all, because I have heard of this solution before, and also because of the hassle of mailing them back to Japan.  Does unplugging them for a week to a month solve the channel imbalance issue in most cases?

post #4 of 8

Yes, and also the distortion (most likely some form of crackling or problems in the bass).

 

I have had situations where a week was insufficient but a month was.

post #5 of 8
Thread Starter 

Do you think the problem may have occurred because I kept the phones continually plugged into the amp?  I shut off the amp every night but always kept the phones plugged in.  Is it better preventive maintenance to unplug the phones from the amp every time you are finished listening to them?

post #6 of 8

No. I have the same amplifier. It is safe to leave them plugged in, and imbalance as a result of parasitic charges can spontaneously develop from silly things such as temperature/humidity changes. In other words, incidences of imbalance can be random.

 

A dust cover may help.

post #7 of 8
Thread Starter 

Duly noted.  I have always left them on a bentwood headphone stand under an official Stax clear dustcover -- only the best.  I didn't know these 'stats were such delicate flowers.  Luckily, I have an almost indestructible unmodified Fostex T50 RP which will substitute during the Stax's hiatus.


Edited by glorkaglickflic - 4/10/14 at 4:14pm
post #8 of 8
Thread Starter 

I kept them unplugged for two weeks and the imbalance issue came back after a few minutes of being plugged in again.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Stax SR 507 channel imbalance