or Connect
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Sennheiser HD 580 Cable/Plug issues
New Posts  All Forums:Forum Nav:

Sennheiser HD 580 Cable/Plug issues

post #1 of 6
Thread Starter 
I have recently brought back from retirement my old Sennheiser HD 580 phones. Thoroughly enjoying them all over again with all the new music that has been made since I 'retired' them some 5 years ago.

A re-occurring issue that I have is the loose connection between the male and female cable plugs. I have tried using Silver conductive paint which works for a while but then the contact starts to beak up again.

Any suggestions welcome. I have heard of some owners going so far as the hard solder the leads into the phones which seems a bit drastic!. However willing try anything, would also send them off for modding if someone in the UK can be recommended.
post #2 of 6

Ooh, doesn't sound good. Do you think it is maybe just the cable connector that is causing the problems? 

post #3 of 6

Check out this video, it may help.

 

http://www.youtube.com/watch?feature=player_embedded&v=mBpic9jbjzs

 

Tim

post #4 of 6
Thread Starter 
Perfect, Thank-you. I think this explains where the contact is breaking down.

I need to decide whether to try and replace the springs, or maybe see if the later drivers for the 600 or even 650 will plug into the 580 if I buy the whole driver it saves messing about with the springs and in theory upgrades the phones at same time??
post #5 of 6
Quote:
Originally Posted by too old to rock View Post

Perfect, Thank-you. I think this explains where the contact is breaking down.

I need to decide whether to try and replace the springs, or maybe see if the later drivers for the 600 or even 650 will plug into the 580 if I buy the whole driver it saves messing about with the springs and in theory upgrades the phones at same time??


The drivers for the HD600 are the exact same part # as the HD580s. Or, at least they were when 580 parts were still available. Many agree the wire grilles account for any difference in the sound between the 580 and 600.

 

Tim

post #6 of 6
Thread Starter 
Thanks Tim, This is what I have done

As you say the replacement driver these days is the 300R which the same for the 580/600/650, I understand the damping materials have been updated in time so sound would probably differ but hopefully improved. If you check replacement grills they also now the same for all 3 models as guess the plastic grill from the 580 no longer available.
So I have order from Sennheiser uk .......

Grill replacement (092815) 2 x £10.24 £20.47
Foam disc (049789) 2 x £0.41 £0.82
Cable straight with 6.35mm stereo jack plug (3m) (092885) 1 x £11.27 £11.27
Dynamic neodymium capsule (300R) (092855) 2 x £37.87 £75.74

So I get the lot for £112 including delivery.

Now as a new pair of 650s still going at around £300 on amazon that seems to make sense

I can then 'play' as much as I want.
I can try 580 lead versus 650 lead
580 grill versus 650 grill
and if I decide for any reason I prefer the sound of the older drivers (which sure I wont) I will take the new spring clips from the connectors and fit them to my old 580.

More than I had intended but sounds like a fun project to amuse myself with.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Sennheiser HD 580 Cable/Plug issues