Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Marantz SR240 sounds Echoey and leans to the right.
New Posts  All Forums:Forum Nav:

Marantz SR240 sounds Echoey and leans to the right.

post #1 of 4
Thread Starter 
Not sure whats wrong with it. If anyone has any ideas please say so.

Basically I have it hooked up from my PC via the 3.5mm jack and plugged into a 3.5mm to RCA (red and white) converter then plugged into the back of it. Thats really all I can say. I'm trying to use it with DT990 250ohms and right now they sound louder and better from my front audio port on my PC. (front audio is hooked into onboard audio as is the converter)
post #2 of 4
Thread Starter 
Bah I had the RCA cables plugged into the phono port. Plugged them into CD/Aux and that works better but its still doesn't sound as good from my onboard audio and is definitely quieter.

Any idea why this receiver can't seem to drive these headphones? I can't find the impedance on them anywhere.

Also plugged into my onboard I am getting alot of extreme sibilance, the letter S isn't sounding like an S anymore its more like a screech.
post #3 of 4
Thread Starter 
I should clarify. When using the phono inputs it was echoey/distorted and overall just bad but it is louder (the loudness isn't whats causing the distortion because my PC gets just as loud), when using the Aux in its clear just seems underpowered. The bass is alot lower than on my onboard audio.

But the good thing is even though underpowered I do know I like them. Well aslong as the bass gets better, right now its present and alot better than my gaming headset (vengeance 1500) but not really where I want it.
post #4 of 4
Thread Starter 

So the consensus is that the marantz simply can't drive these?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Marantz SR240 sounds Echoey and leans to the right.