or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › I need HELP with the Schiit Magni amp......
New Posts  All Forums:Forum Nav:

I need HELP with the Schiit Magni amp......

post #1 of 4
Thread Starter 

Okay, FedEx dropped off my Schiit Magni amp today. Super excited about getting it hooked up. I unpacked it, hooked everything up and I'm trying to decide if something is wrong with my setup. I am using it with my PC which has a ASUS Xonar DG installed it.  SQ with just the Xonar card is really good but I wanted something with a little more umph to it for my HD 600s. 

 

The Xonar DG does not have RCA outs.  It only has a headphone out on the back that uses a 3.5mm plug.  So, I picked up a cord with a 3.5mm plug on one side and 2 red/white RCA plugs on the other side from a seller on eBay to connect from the Xonar DG card to the back of the Schiit amp.  I figured this would suffice but now that everything is hooked up, I am some what disappointed at the SQ.  I'm wondering if I what I envisioned as the proper way to hook everything up is flawed.

 

I get sound but it sounds somewhat muffled and muddy on my HD 600s.  I have the volume on the Xonar DG set at 50% and the volume on the Schiit at 50%.  I've tried it at higher levels but there doesn't seem to be any difference in SQ.  I experimented with the built in gain on the Xonar DG card but it seems to have no effect.

 

I also have a $35 Altoids tin can CMOY battery powered amp and to be honest, the SQ from it is much better with the HD 600s.  The CMOY amp is clear and sharp and I can turn the volume up on it to ear piercing levels without much degradation in SQ.  But on the Schiit, as I crank the volume up, it seems that the SQ doesn't improve and may actually get a little worse.  The Schiit just doesn't have the clarity and SQ of the little battery powered CMOY amp. 

 

What is going on?  What have I done wrong?  Is it the splitter cord? 

 

I really want to like the Schiit Magni amp.  It has gotten rave reviews.  It must be something in my setup. 

 

HELP !!!!?????

post #2 of 4

I don't think the Xonar DG has a plain line-out. So you're double-amping the signal, which might not be working well with that particular setup. Maybe you should try hooking up the audio to the magni directly?

 

But here's the thing with amps and dacs. The improvement in SQ can vary, but generally it's very slight and nothing earthshattering especially if your on-board DAP is already transparent... then you might have to do close A/B tests to notice any differences at all. The impressions one gets from reading all the reviews (the level of over-exaggeration baffles me) is that getting a new amp will transform your headphones. Not one bit true. I think yours is also a case of unrealistic expectations.


Edited by viralcow - 3/21/14 at 7:11pm
post #3 of 4
Thread Starter 
Quote:
Originally Posted by viralcow View Post
 

I don't think the Xonar DG has a plain line-out. So you're double-amping the signal, which might not be working well with that particular setup. Maybe you should try hooking up the audio to the magni directly?

 

But here's the thing with amps and dacs. The improvement in SQ can vary, but generally it's very slight and nothing earthshattering especially if your on-board DAP is already transparent... then you might have to do close A/B tests to notice any differences at all. The impressions one gets from reading all the reviews (the level of over-exaggeration baffles me) is that getting a new amp will transform your headphones. Not one bit true. I think yours is also a case of unrealistic expectations.


The Xonar DG has a headphone out on the back that requires a 3.5mm plug.  There are no RCA outs on the Xonar DG card.  That is why I bought the splitter cable on eBay.  It has a 3.5mm plug (that I have plugged into the Xonar DG) on one end and two RCA plugs (white and red that are plugged into the Schiit Magni).  Thinking maybe this is not the ideal setup to use the Schiit amp?  Maybe?

 

The Xonar DG card does have pretty decent headphone amp built in.  I think it is rated to run up to a 150 ohm headphone and it does a decent job on its on with the HD 600.  But, from everything I have read, I really need a little more power (larger amp) to run the HD 600.  This is why I bought both the Schitt Amp and the CMOY amp.  And yeah, with the CMOY amp, I can tell a difference in the SQ.  It is about 30% better than the Xonar DG, by itself.  But, with the Schiit, the SQ is maybe 5% better but still is not as clear and sharp as the Schiit.  Your right, I did expect more noticeable performance from the Schiit.  I am double amping but it doesn't seem to effect the CMOY amp. 

 

I disabled the Xonar DG and plugged the Schiit amp directly into the onboard sound (after I re enabled it) but the SQ was actually worse.

 

Does any of this sound normal or typical?  Should I expect more performance from the Schiit?

post #4 of 4

Xonar DG have 3 x 3.5 mm jack (1/8") (Front out/Side out/Center-Subwoofer out),

try to do following:

1) connect Schiit Magni to the Side out, configure DG to the 4 speakers setup.

2) use Foobar with ASIO and configure Foobar output to 2 side out connectted channels (in ASIO setup)

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › I need HELP with the Schiit Magni amp......