or Connect
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Loud turntable hum even with ground wire connected
New Posts  All Forums:Forum Nav:

Loud turntable hum even with ground wire connected

post #1 of 2
Thread Starter 

Hi Head-Fi,

 

So I've just set up my first turntable and everything is going fine except than the loud humming.

 

It becomes a lot quieter only when the ground wire is connected and  I touch the screw or the surrounding area at the same time.

 

So using that information, can anybody diagnose the underlying issue and explain possible methods I could take to resolve it?

 

EDIT: Nevermind, I had the phono plugs in the wrong part of the amplifier Doh! No hum now even without the ground wire connected, weird.


Edited by KElyas - 3/20/14 at 1:55pm
post #2 of 2
Quote:
Originally Posted by KElyas View Post

Hi Head-Fi,

So I've just set up my first turntable and everything is going fine except than the loud humming.

It becomes a lot quieter only when the ground wire is connected and  I touch the screw or the surrounding area at the same time.

So using that information, can anybody diagnose the underlying issue and explain possible methods I could take to resolve it?

EDIT: Nevermind, I had the phono plugs in the wrong part of the amplifier Doh! No hum now even without the ground wire connected, weird.

Try running another wire from the grounding post to the screw that holds the faceplate of the closest electrical outlet, while the TT ground is connected to the grounding post, of course. Good luck.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Loud turntable hum even with ground wire connected