or Connect
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › My HE-5LE just died again!
New Posts  All Forums:Forum Nav:

My HE-5LE just died again!

post #1 of 4
Thread Starter 

Grrr! I bought the first set used in October 2011. They worked great until July 2013. Then one driver cut out, just out of the blue. Fair enough, Hifi-Man took care of it. The whole thing cost about $130 with shipping because they were out of warranty. Now it's just happened again! That was 7 or 8 months... Am I just that unlucky, or has anyone else had trouble with these? And I take good care of them darn it! Before any anyone asks, I naturally swapped cables and checked the amp out with different cans.. It's the HE-5LE's right driver.

post #2 of 4
Thread Starter 

Well, now they're working again. NOT COMPLAINING! But it's all a little fishy...

post #3 of 4
Thread Starter 

A few days after they started working again, they died again and did not come back to life. So I sent them out for service. This time around, the good folks over at HiFi-Man decided to simply take care of it for me since I'd already had them replaced 9 months or so prior. All I had to do was ship them over. Good deal! So this is me giving them props!

 

I got them back today. It was naturally a long process again. They no longer keep HE-5LE in stock since they've been discontinued for a while, so the replacement units ship from China. Oh well. Getting "stuck" with my old Grado 325i is definitely a first world problem, but still, these are on a completely different level. I'm re-listening to the new Crystal Method album.. And hearing it all for the first time.:beyersmile:

post #4 of 4

So did they ship a new pair or replace the driver for you? Also how much did it cost you this time? 

I'm curious as owner of an older pair of 5LEs....

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › My HE-5LE just died again!