Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Background Noise in DT 990 when used with Magni
New Posts  All Forums:Forum Nav:

Background Noise in DT 990 when used with Magni

post #1 of 3
Thread Starter 

Hello everyone,

 

A while back I bought a pair of Beyerdynamic DT 990 ( 250 Ohm) and then I got a Shiit Magni + Modi to power them.

 

The set has served me well, but there is this annoying, high-pitched background whine that has pestered me for quite a while. I think it is probably a shielding issue. If I move the headphone cable around a bit or straighten it, the noise goes away for a few seconds, but it comes right back when I relax the cable.

 

I have tried moving my Modi and Magni around to try and get less interference from my other computer cables, but it hasn't worked.

 

If I disconnect the Modi from the Magni, the noise is still there, so it it is probably something with the Magni or most likely the headphone cable itself ( I don't hear anything with other headphones but that might be because they aren't as sensitive as the DT 990).

 

Do you guys have any advice on how I cam fix this little nuisance?

 

Thanks for your time.

post #2 of 3

Sounds like a power issue for the Magni. Contact Schiit, they're somewhat fast with customer responses.

 

Have you ran the DT 990 without the amp, just using the analog plug on your computer? That could reduce the possibilities.

 

Also, (sometimes) your phone can cause static/whining issues. Just my 2 cents.

post #3 of 3
Thread Starter 

Thanks a lot for the response. You are right. There is no background whine when I use it with the headphone jack or with my E6. I guess, I will try to contact Shiit and ask if they know what is going on.

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Background Noise in DT 990 when used with Magni