or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Bought some Sennheiser HD 558s, but now having issues using it on my desktop!
New Posts  All Forums:Forum Nav:

Bought some Sennheiser HD 558s, but now having issues using it on my desktop!

post #1 of 4
Thread Starter 

So here's the deal, I owned a pair of HD 555's back in the day before I (for whatever reason) started using headsets for the longest of time. I decided to switch back to a headphone/mic combo after my Razer Megalodon finally died out on me after ~4 years.

I picked up a pair of Sennheiser HD 558's and a Blue Yeti Mic. Here's where the problem starts; If I plug my headphones in the front jack of my PC, I get some very noisy interference that literally makes the 558's unusable. If I plug them in the back, the sound volume is much, MUCH, lower. I literally have sound max'd and it's nowhere near as loud as in the front.

Is there any solution to this? I'm assuming fixing the front jack would require shielding wires or re-wiring in general which I'm not too comfortable with, but is there any way to make the back jack on the computer put out more power like the front? Maybe I should just buy an amp then? If so, any suggestions? I was looking at the FiiO E10 if need be, but I don't know if that's too much or too little for the 558's.

Thanks!

post #2 of 4

What is the make and model of the motherboard?

Have you updated to the latest software/drivers for your on-board audio?

Asus Xonar DG or DGX sound card $18-$40 should fix the problem.

post #3 of 4
Thread Starter 

Mobo: http://oi59.tinypic.com/ilc8k0.jpg

 

No I haven't, honestly have no idea where to even look for these drivers.

post #4 of 4

That board is pretty old now but even so the on-board is Realtek ALC888S which with a S/N of 97dB should be fine.(ish)

 

http://www.realtek.com.tw/products/productsView.aspx?Langid=1&PFid=28&Level=5&Conn=4&&ProdID=141

 

The data sheet says that the rear panel 3.5mm jack defaults to an microphone input not a line out. So check that first.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Bought some Sennheiser HD 558s, but now having issues using it on my desktop!