or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Hiss/crackling with HD650s
New Posts  All Forums:Forum Nav:

Hiss/crackling with HD650s

post #1 of 4
Thread Starter 

Hi

 

I'm getting a slight hiss or crackling noise in the left cup of my 650s when changing the volume on my Fiio e09k or at certain bassy points in various tracks. As I've said it only affects the left cup and only sometimes. I've had the set up a while and ignored it at first as it was a minor annoyance but it's getting to me more and more as I'm used to the sound.

 

Is it a faulty amp, or is the amp just not good enough? I really hope it isn't a fault with the headphones as I'm not sure what my warranty situation is now (they're about 18months old).

 

 

Thanks in advance.

post #2 of 4

It might be the spring in the cable jack on the earcup, which is a minor repair. They get weaker over time and lose connection. I thought they improved that though.

 

You can probably test the set up in order to isolate the problem by using another pair of headphones with that amp playing the bassy tracks.

post #3 of 4
Thread Starter 

Thanks for the reply, I think the spring may be the issue here. I've borrowed another amp and swapped the cable jacks round and the issue has stayed in the left can. At least I know what it is, and they also seem to still be in warranty which is a bonus. I'll be arranging for repair asap.

 

Thanks again for the help.

post #4 of 4
Super! Happy listening (soon).
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Hiss/crackling with HD650s