or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Need help with digital output on Xonar DG (no sound)
New Posts  All Forums:Forum Nav:

Need help with digital output on Xonar DG (no sound)

post #1 of 13
Thread Starter 

My digital output from Xonar dg won't work - there's no sound at all. Can anyone help?

 

- Latest drivers

- Light out of the port works

- Normal non-SPDIF output works

- Control panels: http://imgur.com/AXiuMHM

- I've tried WASAPI and DS in foobar

 

I'm stumped here.. :) thanks in advance.

post #2 of 13
Quote:
Originally Posted by PascalT View Post
 

My digital output from Xonar DG won't work - there's no sound at all. Can anyone help?

 

- Latest drivers

- Light out of the port works

- Normal non-SPDIF output works

- Control panels: http://imgur.com/AXiuMHM

- I've tried WASAPI and DS in foobar

 

I'm stumped here.. :) thanks in advance.

Try disabling the motherboard's on-board audio, in the BIOS.

post #3 of 13
Thread Starter 

Tried it already before with no results.

post #4 of 13
Do you have the Xonar Audio Center GUI installed? There is an option in there to enable the optical out. The SPDIF Out box needs to be checked, and PCM chosen on the dropdown next to the box.
post #5 of 13
Thread Starter 

I can't find the download link for it anywhere. I looked for a while.. any clue? :)

post #6 of 13
Try here:

http://support.asus.com/download.aspx?SLanguage=en&m=Xonar+DG&os=30

The Audio Center may be in the package with the drivers.
post #7 of 13
Thread Starter 

You're right. thanks. When  I run the app it says "No Xonar Device found". It shows in my Device Manager though.. Hmm.

post #8 of 13
Maybe an uninstall/reinstall of the card? Might be worth a shot.
post #9 of 13
Thread Starter 

Tried the unified drivers, still same issue.. ugh. I guess the card is broken somehow, even if it's new.

post #10 of 13
Thread Starter 

Update: tried the "stable" version Unified drivers and finally got access to the control panel.. indeed SPDIF had to be enabled there for the sound to work. I couldn't access it with any other drivers.

 

thanks for the help.. now I can live in peace again ;)

post #11 of 13
Glad it worked out. Now it's time to enjoy music, since that problem is behind you.
post #12 of 13
Quote:
Originally Posted by PascalT View Post
 

Tried it already before with no results.

According to the picture you posted, it looks like the Realtek audio is still enabled?

post #13 of 13
You can have more than one audio source enabled, but need to designate which one Windows is to use. The long way to switch which one you want to use involves going through Control Panel and navigating through the settings.

Or, I have found a handy little program to use to switch audio - https://code.google.com/p/audioswitch/

This can be placed in your start up folder or taskbar for quick access. It has worked great for me.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Need help with digital output on Xonar DG (no sound)