or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › No sound when using optical digital output
New Posts  All Forums:Forum Nav:

No sound when using optical digital output

post #1 of 3
Thread Starter 

Onboard Sound: ALC 888s
external DAC/amp: Fiio E17
Connection: ALC 888s out----Optical digital cable-----Fiio e17 SPDIF in


I do not get sound when I set Realtek Digital Output (Optical) as my playback device. I tested the cable and fiio e17 on my PS3 and it works fine. I tried on windows 8.1 and windows 7 and it has the same result. I notice that when i connect or disconnect the cable, Realtek does not say anything.

I have the latest sound drivers and i made sure the sound format was stereo and not surround.

 

any1 know what's the problem? 

post #2 of 3

Right click the little speaker at the bottom right--> Playback devices

 

Go down the list to the Realtek Digital Output (Optical), select it and click Properties

 

In the Supported Formats tab, check every Encoded format option, and every Sample Rates option

 

In the Enhancements tab, check Disable all sound effects

 

In the Advanced tab, select: 2 channels, 24bit, 44100Hz (Studio Quality)

 

Click Apply, then Ok, and open Foobar (I'm guessing you use foobar?)

 

In the Foobar preferences, click on the Outputs option in the left side menu

 

Under DEVICE, select: WASAPI: Realtek Digital Output (Optical)

 

Under Output Format, make sure you have 24bit selected (or 16bit, if you chose 16bit in the Advanced tab of your Playback device property earlier), 32bit is not supported by Realtek and it's likely why you're not getting any sound.

 

Hope that solved your problem.

post #3 of 3
Thread Starter 
Quote:
Originally Posted by elmoe View Post
 

Right click the little speaker at the bottom right--> Playback devices

 

Go down the list to the Realtek Digital Output (Optical), select it and click Properties

 

In the Supported Formats tab, check every Encoded format option, and every Sample Rates option

 

In the Enhancements tab, check Disable all sound effects

 

In the Advanced tab, select: 2 channels, 24bit, 44100Hz (Studio Quality)

 

Click Apply, then Ok, and open Foobar (I'm guessing you use foobar?)

 

In the Foobar preferences, click on the Outputs option in the left side menu

 

Under DEVICE, select: WASAPI: Realtek Digital Output (Optical)

 

Under Output Format, make sure you have 24bit selected (or 16bit, if you chose 16bit in the Advanced tab of your Playback device property earlier), 32bit is not supported by Realtek and it's likely why you're not getting any sound.

 

Hope that solved your problem.

got it fixed. I opened up my computer and i switched to another spdif header. Maybe it was defective or it was loose. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › No sound when using optical digital output