or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › No sound from Grado SR325i headphones (possibly need re-cabling) Based in UK
New Posts  All Forums:Forum Nav:

No sound from Grado SR325i headphones (possibly need re-cabling) Based in UK

post #1 of 2
Thread Starter 

Hi everyone,

 

Have spent the past few hours trying to find out whats wrong with my headphones and people I have asked seem to think its the cable, but I am not sure. I am unable to find suitable information on where to buy all the required parts to re-cable my Grado SR325i headphones.

 

My issue:

Headphones worked for well over a year, then sound started cutting in and out for a few months (a gentle knock seems to fix it)

 

Now they have stopped working altogether, no sound coming from at all.

 

I have managed to remove the plastic cup from the can using a hair dryer to heat the glue on one of them and the solder doesnt look suspicious. When I connect the headphones to some speakers playing music, the music stops playing from the speakers, so am I right in thinking the cable is fine and the problem is much more sinister? or will the sound stop regardless of the cable being broken?

 

If you think re-cabling may fix them, I would like to do this myself but no clue on the parts needed to make a new cable.

 

Thanks

post #2 of 2

Try contacting grado in the UK for an inquiry. 
http://www.grado.co.uk/grado-headphone-repair.htm
 

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › No sound from Grado SR325i headphones (possibly need re-cabling) Based in UK