or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Basic question on tube amp power cable
New Posts  All Forums:Forum Nav:

Basic question on tube amp power cable

post #1 of 4
Thread Starter 

I bought a Darkvoice 336i earlier today, and found it came with the wrong power cord (the seller had an aftermarket cable and handed me another one when I bought the amp). After a bit of digging, I unearthed a grounded 3-prong cord, which is rated 125V10A. The Darkvoice's input says '220V50Hz, Fuse 1A'—is it referring to the voltage, frequency and fuse in my mains, or do I need a different cable?

 

The question seems so inane that I haven't been able to find any threads on it, but the last thing I want is to blow my first amp.

post #2 of 4
Whoa... What country are you in and did you buy this amp in the same country where you live? What is the AC spec of the power at your house?
post #3 of 4
Thread Starter 

I'm in the UAE—our mains are 220V, 50Hz. Just petrified of wrecking my gear before I even have a working setup (waiting on a friend to replace his MusicStreamer II+ so I can buy it off him).

post #4 of 4
I would get the proper cord for your amp. I would think any appropriate 220v modular power cord would work - but I don't think you want to be messing around with parts rated for 125V when your wall outlet is supplying 220v. Take a trip to the UAE equivalent of Home Depot...
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Basic question on tube amp power cable