or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Need Help with Schiit Modi noise
New Posts  All Forums:Forum Nav:

Need Help with Schiit Modi noise

post #1 of 2
Thread Starter 

Hello all, first time poster here. I recently got the Schiit Magni/Modi stack and I love the sound, but the Modi has some noise issues. It was the typical oscillating whine of a noisy motherboard. So I ordered a ADUM4160 based usb isolator (http://hifimediy.com/index.php?route=product/product&product_id=122) The oscillation I initially heard is gone, but now there is a very noticeable high pitched whine whenever music plays. The whine continues for a short time after music plays and then stops, starting up again after something else plays.

 

System info: (just in case)

Windows 8.1

Running off a separate usb 3.0 card (http://www.amazon.com/gp/product/B005ARQV6U/ref=oh_details_o03_s00_i00?ie=UTF8&psc=1)

-The Noises are present on all controllers attached to system

Tested on Senn HD598 and Audio Technica Ath-ANC7b (HD598 is out for repair currently)

 

Is there something wrong with the isolator or is it something else? I need the wisdom of the headfiers.

I will be testing on another computer shortly. 

 

If any of you can help, please do, I will be forever in your debt.

post #2 of 2
Thread Starter 

I've tested the isolator on a laptop running off battery power, same high pitched noise, can someone confirm that the isolator is no good?

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Need Help with Schiit Modi noise